Jump to content
InsanelyMac Forum
Vustom

5.1 sound on ALC888S

Recommended Posts

I'm using a modified AppleHDA.kext which makes the 2.1 sound and Mic work but I got new 5.1 speakers and I can't get them to work. There split up to 3 different outputs in the Sound preferences. I've tried joining them together as seen on some YouTube tutorials but it still only plays through far left and far right, left and right or bass and center.

I can't get them all to work at the same time. Any ideas?

i've seen this post: http://www.insanelymac.com/forum/topic/293001-mavericks-realtek-alc-applehda-audio/ but I don't understand what to do..

Share this post


Link to post
Share on other sites
Advertisement

 I don't understand what to do..

Which step is the problem?

  1. Applications/Utilities/Audio MIDI Setup/Audio Devices/+/Create Aggregate Device
  2. Select (in order)
    1. Built-in Output
    2. Built-in Line Output (1st)
    3. Built-in Line Output (2nd)
  3. Configure Speakers
    1. Multichannel
    2. 5.1 Surround
  4. Apply/Done

Screenshots: Download/View Raw, M-Realtek_ALC_AppleHDA_Screenshots.pdf.zip

Share this post


Link to post
Share on other sites

I've tried this, I've setup the configuration up perfectly but it still only plays from 2 out of 6 speakers.

OS X 5.1 sound requires 5.1 source and a 5.1 player.  What source?  What player?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×