Jump to content

sudo issues (no root user found?)


1 post in this topic

Recommended Posts

Hi!  I've been having troubles running sudo.  I'm currently in Windows, but I think the line that comes up when I sudo is along the lines of "Unable to cache user root: already exists" or something like that.  I'll confirm the error once I'm back in OS X.


However, I cannot say that my installation was problem-free.  I used a previously created myHack Mountain Lion installer to install it on an MBR partition (however, it wasn't primary, but logical).  If any of you are familiar with how myHack works, with about a minute left of the install, myHack begins to run.  This will install Chameleon, prompt you for an Extra folder, and remove problematic kexts by a prompt before finishing the install.  The Extra folder prompt came up, but then, all of a sudden, the install appeared to hang before the problematic kexts prompts came up.  I let it sit for about 30 minutes and no progress, so I rebooted and tried to boot.  It worked, but the account generated was a Standard user account.  I figured out from various threads and managed to convert my account to an Administrator account, but then I found out I can't sudo because of that error.


I tried the Directory Utility to enable the root user, but I can go from enabling to disabling the root account without it doing a thing.  I also tried rebooting into single user mode to reset the root password.  Enabling write support and then typing passwd, I found out that apparently, there is no root account, period.  It can't find a user named "root" to change the password for.  I tried googling around, but the only thread I found that was even remotely relevant was from a certain Tonymacwannabex86, with one user describing my exact issue, but then that very same user went on describing how to fix the problem of making your account an administrator.  Very useful, right?  I thought so.


So, basically, I'm at a loss for words.  I'm hoping that someone here would know.  Anyone have any suggestions!?!?

Link to comment
Share on other sites


  • Create New...