Jump to content

Random Freezing and Lock ups AMD fx


1 post in this topic

Recommended Posts



My system is as follows:


Amd fx-8120 cpu

Gigabyte 990fxa-ud5 board

Xfx 7870 2gb ghz core edition device id 1002 6818

16gb Patriot 1866mhz - cant get higher then 1333mhz with this cpu tho crashes

2x Ocz Vertex3 120gb ssd - 1 gpt for mavericks - 1 mbr for win 8.1 pro / opensuse 13.1

5x 500gb wd5000 hdd all gpt for virtualized opensuse system btrfs raid 5

1x Sata dvd burner

Kuhler 920 watercooling

2 psu - Ocz 700 watt for board and drives / 400 watt Antec for Graphics

3x 23.6" Asus led screens


Alright I'm a designer / web /mobile / game developer, I despise windows I only want to use it as a gamer or for testing stuff i've coded. I used to run a linux base system and 2 video cards passing one thru to virtual machines using kvm and vfio. I find the performance to be too slow to use for any type of workstation apps, eg Creative Cloud. So I decided to run a mac base and virtualize linux for my data and downloaders etc. and dual boot windows if I need it. Well mavericks installs great using bootlfags amdfx GraphicsEnabler=No PCIRootUID=1 -v I used these posts as a guideline...





The problem is once installing is completed, I boot into mavericks using "KernelCache"=\amd GraphicsEnabler=No PCIRootUID=1 -v I get to setting up a user and that seems to work fine, once it hits the setting up mac screen and switching to the desktop the graphics seem to lock up. The mouse cursor just spins and I can move the mouse but the desktop freezes in mid transition. All I can do is reboot. The system runs 100% solid using -x flag but its useless to me as I need acceleration. Sometimes it will run fine for awhile with the acceleration enabled others I can't even login. The system itself doesnt seem locked up tho as I did luck out and get virtualbox running my linux box, once the graphics locked up I was unable to use the desktop but was able to ssh in and use my servers in the virtual machine running from another box. It also seems to act like its fsb is overclocked too high or lack of a proper psu thats not the case at all I'm running stock speeds just to make sure, this only happens in mac. I've also tried using my older asus 6950 1gb video card, but no matter what I do I cant get the graphics working with it either, just white screen tried the sleep trick etc nothing, only -x works or having the graphics kexts pulled out. This is absolutely frustrating any and all help will be greatly appreciated. This is my first attempt at an ask for help, been at this for a few weeks now sorry about the rambling just wanted to explain everything I could think of.


Also no kernel panics nor anything of use in console logs, only seems to say agpm controller not found, Ive also added my device id to the graphics power management kexts and it then found the controller but still no luck same issues, Only 2 screens work too 3rd is black using 7870




Link to comment
Share on other sites


  • Create New...