Jump to content

Can only Boot in Safe Mode


13 posts in this topic

Recommended Posts



The whole last week i spent to get my Hackintosh running. But it didn't work for me. I need Help from users with more experience in building a hackintosh.


First of all my Specks:

-i7-2600K @ 3,4 GHz (no Turbo enabled, no Speedstep enabled)

-P8P67 3.0  BIOS 3602

-XFX HD6970

-2x 4GB G-Skill DDR3 Ram @ 1600 MHz

-2 Crucial M5 SSD S-ATA 600

-500GB HDD WD Black S-ATA 300


I used a VMachine with Mavericks 10.9.0 to download Mavericks 10.9.1 from App Store.

I made a bootable USB-Stick GUID. Manually (Restore BaseSystem.dmg and copy Packages to it) and install the latest Chameleon bootloader 2.2 SVN R377. I restardet the Computer, turn intel vtd off and bootet from usb STick.It didnt showe me chameleon, instead of it directly went to install Screen.

I installed Mavericks on one SSD and a 2nd time at HDD. But i couldn'T boot into the installed driver with the USB Stick.

I Recreated a bootable USB-Stick MBR using #####. and could boot into the installed drives using -x. With my Hack it stunning att mousewheel spinning. And my fix doesn't run under safe Mode.

I boot into SSD and tried to make the HDD bootable. With Chameleon ->only Safe mode.I created the right smbios.plist imac 12,2 using Chameleon Wizard. And tried many Options for org.chameleon.bootlist. Only Safe mode or i crashed the installation that so I was even unable to boot in safemode. When i Try to boot normally it give me a kp appleintelcpupowermanagement Faullt CR2 Or a white Screen bug. 

I tried patched apple cpupowermanagement, different fakesmc versions, adding nullcpupowermanagement, but everytime the same result. Unbootable.

I tried Andy's P8P67 Package, P8P67 Pro Package for Post iNstall. or P8P67 Por USB Package to make the Usb Stick bootable.( Doesn't boot into Install)  and for Post install. I buyed me a new USB-Stick. Find dirrefent topics about flashing bios. I had BIso Version 3602. I Flashbacked it to 2103 and installed a flashed 2303. I Flashed 3602.rom using pm patch.But didnt install it actually I have the 2303 modified running. It gives me no kp's but white sceen errors. Graphics Enabler YES OR NO, IGP ENabler Yes or NO. NPSCI=0x2000 or 0x3000 nothing soplved my problem. 

I USed Linux LIve CD to extract DSDT.aml and compiled it under safe mode osx. put into chameleon bootlist. Repaired after each post install kext utility.


First I didn't want to post a topic, I used google to read a lot.about  Fixing such problems. One week of my holyday is now gone. I tried so much. But it don't work. Please, if someone has the same parts like mine running a stable hackintosh with Mavericks 10.9.1 on it.HELP ME


I speak German, English and Russian. 


Help me which Bios i Should choose patched 2303,normal 3602 or patched by myself 3602 ( Iconsidered a lot but not installed, yet)

Which Chameleon Bootloader. ( I think the latest one would be the best choice)

A Org.Chameleon bootlist with smbios.plist. Which flags to add.

Maybe a patched DSDT.


I posted it chaosly and not in the best english, Sry for that, i hope you unterstand me. I tried so Much, my hair is going to be gray when I don't make that. The performance of my VM Mavericks insn't the best with 128MB Graphics virtualisized. 


When i can boot the Post install is my problem, I first try by myself.Or Post a Topic in Post Install Direction.



That is my first Hackintosh, i dont want to have Windows anymore.Its Installed on my First SSD when i made  running this i erase it and make a hardware raid of my SSD'S.



Thanks a Lot for everyone who will read that roman and tries to Help Me.


At the Moment i Have no camera but i try to borrow one. I tried different version of chameleon bootloader and the same result erverytime. On SSD after reinstall i get gpt0 Test error. i'm confused, but with usb stick i can boot into it using -x.






I installed original 3602 bios rom and will try to patch aicpm. her my chameleon bootlist with iit i was able to start the installer but no menu appaerded.

<key>Boot Graphics</key>
<key>Kernel Flags</key>
<key>Legacy Logo</key>
<key>Quiet Boot</key>



i followed most of my time this guide http://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners-updated-for-mavericks/

Link to comment
Share on other sites



First, i gave to you a solution to install OSX… check this and please try use it, it’s very useful…

Second, We don’t give support for tonymac’s tools… check my signature to know why…

Try use that solution i gave to you and install OSX… if you cannot install… please post a picture of error…

Your mono has UEFI?

After install OSX use this guide to install Chameleon: http://www.insanelymac.com/forum/topic/295630-instala%C3%A7%C3%A3o-e-configura%C3%A7%C3%A3o-do-chameleon-bootloader/
Set your mono for legacy_boot mode if your mono has UEFI, because Chameleon just work in legacy_boot…

Guide to get fully Power management: http://www.insanelymac.com/forum/topic/295587-power-management-for-sandyivy-bridgehaswell-cpus/

  • Like 1
Link to comment
Share on other sites

I've followed your instructions. First it gaves me a kp loading the usb installer. After turn on optimzed defaults settings in my bios i could start the installation from usb. I plugged in only my SSD and all not necassery things off. Installed Mavericks with Succes but when I try too boot threw usb stick, it gives me a whitescreen with unmediately restart.


So i could not install chameleon or AICPMpatch. 

Link to comment
Share on other sites



my bios is set to legacy mode, and usb 2 legacy is enabled. What do you mean with set your mono to legacy mode. When i start my Computer and press F8 i can choose between between Kingston Data Storage and UEFI Kingston Data storage. I choosed the normal one, so i think its in legacy mode. i booted osx mavericks install usb and installed mavericks on my hdd. the i restart choose the usb stick. it Loads the theme of clover and when i pick my HDD with installed Mavericks it boots in verbose mode and npci 0x2000. It loads everything. no kp. but where usially i can add my account information its only a white screen and then it restarts. i can't understand it.


in -x it starts and gives me a screen with adding my account information, but no ethernet connection were detected. i dont want to boot in safe mode, i think i need only the right boot flags. In the menu of clover it recognized my complete system.

Link to comment
Share on other sites

When I boot from USB and went to about clover it shows me:

running on EFI Revision 2.31

Platform:x86_X64 (64bit)

Firmware Clover rev 2236

Screen Output GRaphics Output (UEFI), 1280 x 1024




I Don't use my HD Graphics 3000.I have a P board not a H or Z. You mean boot in safe mode and delete this kexts may fix it. The bootloader use my default screen, plugged in my HD 6970. I will try.

Link to comment
Share on other sites

hello after reboot with white screen and booting in safe mode i get this error log. 

Anonymous UUID:       4C3DE597-107B-54C8-8E91-F6ADFA741C29

Thu Feb 27 11:24:59 2014
panic(cpu 6 caller 0xffffff80002dc19e): Kernel trap at 0xffffff7f81b5de3b, type 14=page fault, registers:
CR0: 0x0000000080010033, CR2: 0x0000000000000020, CR3: 0x000000001551b01c, CR4: 0x00000000000606e0
RAX: 0x0000000000000000, RBX: 0x0000000000000004, RCX: 0x0000000000000000, RDX: 0x0000000000000006
RSP: 0xffffff80f4963b40, RBP: 0xffffff80f4963b70, RSI: 0x0000000000000000, RDI: 0xffffff8018157400
R8:  0x0000000000000000, R9:  0x0000000000000008, R10: 0x0000000000000000, R11: 0xffffff80005ee610
R12: 0xffffff801812e000, R13: 0xffffff80182a3c00, R14: 0x0000000000000000, R15: 0x0000000000000005
RFL: 0x0000000000010246, RIP: 0xffffff7f81b5de3b, CS:  0x0000000000000008, SS:  0x0000000000000010
Fault CR2: 0x0000000000000020, Error code: 0x0000000000000000, Fault CPU: 0x6

Backtrace (CPU 6), Frame : Return Address
0xffffff80f49637d0 : 0xffffff8000222f69 
0xffffff80f4963850 : 0xffffff80002dc19e 
0xffffff80f4963a20 : 0xffffff80002f3606 
0xffffff80f4963a40 : 0xffffff7f81b5de3b 
0xffffff80f4963b70 : 0xffffff7f81b48202 
0xffffff80f4963bb0 : 0xffffff7f81af8afe 
0xffffff80f4963be0 : 0xffffff7f81aebfdd 
0xffffff80f4963c20 : 0xffffff7f817b34d2 
0xffffff80f4963c60 : 0xffffff7f817b7495 
0xffffff80f4963cf0 : 0xffffff7f817af855 
0xffffff80f4963d30 : 0xffffff80006950e3 
0xffffff80f4963d90 : 0xffffff80006ca6d5 
0xffffff80f4963e00 : 0xffffff80002b5b0b 
0xffffff80f4963e50 : 0xffffff8000226bb1 
0xffffff80f4963e80 : 0xffffff80002139b5 
0xffffff80f4963ef0 : 0xffffff800021e003 
0xffffff80f4963f70 : 0xffffff80002c921d 
0xffffff80f4963fb0 : 0xffffff80002f3e26 
      Kernel Extensions in backtrace:
            dependency: com.apple.iokit.IOPCIFamily(2.8)[447B4896-16FF-3616-95A2-1C516B2A1498]@0xffffff7f808ba000
            dependency: com.apple.iokit.IOPCIFamily(2.8)[447B4896-16FF-3616-95A2-1C516B2A1498]@0xffffff7f808ba000
            dependency: com.apple.iokit.IOGraphicsFamily(2.3.6)[38E388A5-92D6-3388-B799-F2498E582287]@0xffffff7f817a6000
            dependency: com.apple.iokit.IOAcceleratorFamily(98.7.1)[024BF8EC-2925-3C4B-ADBB-CFE36F7D41C5]@0xffffff7f81aeb000
            dependency: com.apple.iokit.IOPCIFamily(2.8)[447B4896-16FF-3616-95A2-1C516B2A1498]@0xffffff7f808ba000
            dependency: com.apple.iokit.IOGraphicsFamily(2.3.6)[38E388A5-92D6-3388-B799-F2498E582287]@0xffffff7f817a6000

BSD process name corresponding to current thread: WindowServer
Boot args: -v npci=0x2000  slide=0 

Mac OS version:

Kernel version:
Darwin Kernel Version 13.0.0: Thu Sep 19 22:22:27 PDT 2013; root:xnu-2422.1.72~6/RELEASE_X86_64
Kernel UUID: 1D9369E3-D0A5-31B6-8D16-BFFBBB390393
System model name: iMac12,2 (Mac-942B59F58194171B)

System uptime in nanoseconds: 22965323180
last loaded kext at 22835297881: com.apple.driver.AppleUpstreamUserClient	3.5.13 (addr 0xffffff7f81f1a000, size 28672)
loaded kexts:
net.osx86.kexts.GenericUSBXHCI	1.2.6
org.netkas.driver.FakeSMC	901
net.osrom.kext.Disabler	1.0.1
com.apple.driver.AppleUpstreamUserClient	3.5.13
com.apple.driver.AppleMCCSControl	1.1.12
com.apple.kext.AMDFramebuffer	1.1.4
com.apple.iokit.IOUserEthernet	1.0.0d1
com.apple.AMDRadeonX3000	1.1.4
com.apple.driver.AGPM	100.14.11
com.apple.driver.AppleTyMCEDriver	1.0.2d2
com.apple.Dont_Steal_Mac_OS_X	7.0.0
com.apple.driver.AppleSMCPDRC	1.0.0
com.apple.kext.AMD6000Controller	1.1.4
com.apple.driver.AppleLPC	1.7.0
com.apple.driver.AppleHWAccess	1
com.apple.driver.AppleIntelSNBGraphicsFB	8.1.8
com.apple.driver.ACPI_SMC_PlatformPlugin	1.0.0
com.apple.driver.AppleFileSystemDriver	3.0.1
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless	1.0.0d1
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib	1.0.0d1
com.apple.BootCache	35
com.apple.iokit.SCSITaskUserClient	3.6.0
com.apple.driver.XsanFilter	404
com.apple.driver.AppleFWOHCI	4.9.9
com.apple.driver.AppleUSBHub	650.4.4
com.apple.driver.AppleUSBXHCI	650.4.3
com.apple.iokit.IOAHCIBlockStorage	2.4.0
com.apple.driver.AppleAHCIPort	2.9.5
com.apple.driver.AppleUSBEHCI	650.4.1
com.apple.driver.AppleRTC	2.0
com.apple.driver.AppleACPIButtons	2.0
com.apple.driver.AppleACPIEC	2.0
com.apple.driver.AppleHPET	1.8
com.apple.driver.AppleSMBIOS	2.0
com.apple.driver.AppleAPIC	1.7
com.apple.nke.applicationfirewall	153
com.apple.security.quarantine	3
com.apple.driver.AppleIntelCPUPowerManagement	216.0.0
com.apple.driver.AppleSMBusController	1.0.11d1
com.apple.iokit.IOAcceleratorFamily	98.7.1
com.apple.iokit.IOSurface	91
com.apple.iokit.IONDRVSupport	2.3.6
com.apple.iokit.IOBluetoothFamily	4.2.0f6
com.apple.driver.AppleSMBusPCI	1.0.12d1
com.apple.kext.AMDSupport	1.1.4
com.apple.AppleGraphicsDeviceControl	3.4.12
com.apple.iokit.IOFireWireIP	2.2.5
com.apple.iokit.IONetworkingFamily	3.2
com.apple.driver.AppleHDAController	2.5.2fc2
com.apple.iokit.IOGraphicsFamily	2.3.6
com.apple.iokit.IOHDAFamily	2.5.2fc2
com.apple.driver.AppleSMC	3.1.6d1
com.apple.driver.IOPlatformPluginLegacy	1.0.0
com.apple.driver.IOPlatformPluginFamily	5.5.1d27
com.apple.iokit.IOSCSIBlockCommandsDevice	3.6.0
com.apple.iokit.IOUSBMassStorageClass	3.6.0
com.apple.iokit.IOUSBHIDDriver	650.4.4
com.apple.driver.AppleUSBComposite	650.4.0
com.apple.iokit.IOSCSIMultimediaCommandsDevice	3.6.0
com.apple.iokit.IOBDStorageFamily	1.7
com.apple.iokit.IODVDStorageFamily	1.7.1
com.apple.iokit.IOCDStorageFamily	1.7.1
com.apple.iokit.IOAHCISerialATAPI	2.6.0
com.apple.iokit.IOSCSIArchitectureModelFamily	3.6.0
com.apple.iokit.IOFireWireFamily	4.5.5
com.apple.iokit.IOUSBUserClient	650.4.4
com.apple.driver.AppleEFINVRAM	2.0
com.apple.iokit.IOAHCIFamily	2.6.0
com.apple.iokit.IOUSBFamily	650.4.4
com.apple.driver.AppleEFIRuntime	2.0
com.apple.iokit.IOHIDFamily	2.0.0
com.apple.iokit.IOSMBusFamily	1.1
com.apple.security.sandbox	278.10
com.apple.kext.AppleMatch	1.0.0d1
com.apple.security.TMSafetyNet	7
com.apple.driver.AppleKeyStore	2
com.apple.driver.DiskImages	371.1
com.apple.iokit.IOStorageFamily	1.9
com.apple.iokit.IOReportFamily	21
com.apple.driver.AppleFDEKeyStore	28.30
com.apple.driver.AppleACPIPlatform	2.0
com.apple.iokit.IOPCIFamily	2.8
com.apple.iokit.IOACPIFamily	1.4
com.apple.kec.corecrypto	1.0
com.apple.kec.pthread	1
Model: iMac12,2, BootROM IM122.0047.B1F, 4 processors, Intel Core i7, 3.41 GHz, 8 GB, SMC 1.72f2
Graphics: AMD Radeon HD 6xxx, AMD Radeon HD 6xxx, PCIe, 2048 MB
Memory Module: BANK0/DIMM0, 4 GB, DDR3, 1600 MHz, G Skill Intl, F3-12800CL9-4GBRL
Memory Module: BANK1/DIMM0, 4 GB, DDR3, 1600 MHz, G Skill Intl, F3-12800CL9-4GBRL
Serial ATA Device: Crucial_CT120M500SSD1, 120,03 GB
Serial ATA Device: WDC WD5002AALX-00J37A0, 500,11 GB
Serial ATA Device: HL-DT-ST BDDVDRW CH10LS20
USB Device: Hub
USB Device: Microsoft® Nano Transceiver v1.0
USB Device: Hub
USB Device: USB Multimedia Keyboard
USB Device: DataTraveler 3.0
USB Device: Vendor-Specific Device
Thunderbolt Bus: 
Link to comment
Share on other sites

I have a new plan. install 10.9.2 on my hdd install chameleon. patch aicpm. add ssdt for my sandybridge i7-2600k supports up to 4,2 GHz turbo. Add smbios.plist imac 12,2 and create org.chameleon bootlist with graphics enabled, Gui, mach_kernel generate P and C states=No, npci 0x2000 -v graphics enabler=Yes and Dropssdt=Yes. What do you think off?

Link to comment
Share on other sites



I have two more questions. Is it necassary to use a dsdt file. I read a lot about creating own dsdt or using one for my p67board, but its also depending on bios version.

2nd question is do i need fakesmc. If the anwser is yes which version?

Link to comment
Share on other sites


I Make a new clean install 10.9.2 using clover.app v3


I never used this method... i hope it will retail... anyway...

Is it necassary to use a dsdt file


Only if you need or want one... if you want create one, give a read in here: http://olarila.com/forum/viewtopic.php?f=19&t=634

do i need fakesmc



Always... FakeSMC simulate SMC... SMC doesn't have in PCs only in Apple Computers and OSX before begin... it check if the Hardware has or not SMC... if it find SMC numbers(like in a real mac)gave by FakeSMC... the system boot


So after installation, comes post-installation and you must install FakeSMC in HDD...

Link to comment
Share on other sites


  • Create New...