Jump to content

Root Device Error with myHack & Vanilla USB methods


3 posts in this topic

Recommended Posts

Hi guys,


I am performing a re-install of my Hackintosh system using legitimate tools, as opposed to "stolen property" from a different web site.


So far I am not having much luck... 


I tried to build a Clover USB stick from RampageDEV instruction without success


I was able to create a myHack USB Install, but it gave be a Root Device Error that I just could not get rid of regardless of what flags I used... 


So I found another tutorial, "Vanilla" install I think it was called, basically doing a manual load of the myHack USB install key, and have the same error.


I have attached a screen shot of the error... I apologize for the crappy quality, I just don't have a good way to do screen captures without being in the UEFI or OS... :/


I will say, that the "stolen property" was able to load up without issue, so there must be something I'm doing wrong here... Frustrating


I'm going to play around with some UEFI settings and see what I can accomplish.


I appreciate any help along the way as well!


Thanks guys!


Link to comment
Share on other sites

I'm installing OS X now...


I believe the fix came when I shifted my USB stick from one of the front ports of the machine (USB 3.0 Controller) to one of the USB 2.0 ports directly on the motherboard.


I had to remove all the NVIDIA kexts from the S/L/E folder though, white screen with a beach ball...


And my drive is showing up as External which I have seen posts about before...


I'll figure it out when the time comes


Hope this little mistake might help someone else in the future... Don't plug in to a USB 3.0 port for the installation!

Link to comment
Share on other sites

Ultimately ended up making another myHack USB drive, and plugged in to a USB 2.0 port, it worked without a hitch once I figured out the right flags to use.


So now I've got a baseline 10.9.1 build... Happy!

Link to comment
Share on other sites


  • Create New...