Jump to content

Intel Series 7 USB3 shutdown


Download-Fritz
 Share

1 post in this topic

Recommended Posts

Hey guys (and non-guys?),

 

After working with my setup for a decent amount of time now, I noticed that my external USB3 HDD won't turn off nicely as you would expect it when you shut down the system, but instead loses power (noticeable because of the "HDD die beep"). I don't have the slightest clue of what could be wrong as the HDD will turn off smoothly when entering sleep mode on both USB3 and USB2 ports. Also, it only happens on USB3 ports. When I plug it into a USB2 port, it turns of nicely as expected.

 

I heard of similar problems for real Macs (even if they were not exactly the same), which could be solved by resetting SMC... but since that is not really what could help for that kind of build, I would be very thankful if anyone knows a possible solution or just reports about similar problems! :)

 

My setup is in the signature, please tell me if you need more.

 

My back USB3 ports worked out-of-box with no further edits or kexts. To get my only front USB3 port working I needed to patch my DSDT, which I first attempted with the tutorial over here and after with PJALM's DSDT patch (which should be the same result, shouldn't it?). As both wouldn't correct my problem, I tried out the GenericUSBXHCI kext. All three methods had the exact same problem described above, on any USB3 port, even without any additional kext or DSDT.

 

If you need anymore details, info, or have only a little clue what could be wrong (even if you're not sure), leave a reply! :) Thanks in advance!

 

Edit 1 (19:24): Sorry, I missed something. I tried USB injection / Ownership fix on and off with all previously mentioned attempts (DSDT, kext, nothing) mixed and none worked out properly either.

 

Have a nice day,

Download.

Link to comment
Share on other sites

 Share

×
×
  • Create New...