Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
bperic83

DEL Inspiron 3420 Hackintosh

22 posts in this topic

Recommended Posts

Hi,

 

I just followed a guide from this forum about installation of Mac OS X 10.9 (http://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners-updated-for-mavericks/) and I can't boot from created USB. I attached the boot screen, it says that my Intel CPU is unknown. Any help with this?

 

I have DELL Inspiron 3420 with:

Intel® Core i5-3210M CPU @ 2.50GHz (Ivy Bridge)

4GB RAM (1600MHz)

Intel HD4000 and GeForce GT 610M (1GB)

post-1282511-0-93364000-1389300512_thumb.jpg

Share this post


Link to post
Share on other sites

I tried this and got this screen. Could it be just because I didn't change SMBIOS frm MacBookPro 9,2 to MacBookPro 10,1? I don't have Mac right now so I could do it in the morning when I come to work :-/ But if this could be solution than it would be worth waiting :)

 

post-1282511-0-03675100-1389301810_thumb.jpg

Share this post


Link to post
Share on other sites

Try -v -f GraphicsEnabler=No

If doesn't work:

  • Delete FakeSMC plugins (Navigate for System/Library/Extensions, FakeSMC.kext; Right click-Show package content-delete plugins folder), smbios MBP 9,2 is ok.
  • See if FakeSMC is also present in Extra/Extensions, then delete plugins from there.

All the best

Sorry for my english

Share this post


Link to post
Share on other sites

Ok, tnx :) Don't worry for english, it is good, we can understand eachother, that is the most important :)

I'll try with -f, too. If it doesn't work I'll delete FakeSMC tomorrow at work, try this again tomorrow, and report in around 24 hours :)

Share this post


Link to post
Share on other sites

I don't have Plugins folder inside Fake SMC.kext, neither in System path, neither in Extra folder :( For FakeSMC.kext I downloaded some folder with many .kext files in it, maybe it is the wrong one/ Can you send me link for download just FakeSMC.kext?


It's ok, I found FakeSMC.kext in download section of forum, downloaded it, copied to USB, and deleted plugins folder :) Now, when I come home from work, in about 9 hours, I'll try install again :)

 

And one more question - I combined Cameleon Wizard org.chameleon.boot.plist from tutorial and one that I got by default in Wizard. So, could you tell me if these settings are ok, or I should change some of them?

 

post-1282511-0-14840500-1389352142_thumb.png

Share this post


Link to post
Share on other sites

Done :) Thanks :) The moment of truth will happen in around 6 hours :D I'll report what happened.

 

I didn't have luck again :( This is screen that I got this time:

 

post-1282511-0-84753500-1389378196_thumb.jpg

 

It looks like it is again unknown procesor ... I think I read somwhere that it don't recognize procesor as it is, but it is coded for a different procesor, and should be changed for example from 0280 to 0245, something like that, not exactlly the same numbers.

Share this post


Link to post
Share on other sites

Hello

 

My advice:

*Enable P and C States

*Disable UseKernelCache

*Uncheck System Type(it isn't necessary)

 

Do you really need ncpi=0x2000? This fix PCI Configuration Begin...

 

Configure your Bios: http://olarila.com/forum/viewtopic.php?f=2&t=1804

*Disable Integrated graphic(HD4xxx) use Didicated(GT610M) let GraphicEnabler enabled

 

Install FAkeSMC and try boot...

Share this post


Link to post
Share on other sites

Moving this to the proper forum: notebooks.

 

Marugby123

InsanelyMac Netbook Moderator

Share this post


Link to post
Share on other sites

Ok, thanks, I'll try this as soon as I get my hand on some Hackintosh and can change this parameters :)

 

I enabled P and C states. Should it be just Generated or Enable C2, C3, C4 too?

About disable integrated graphics (HD4000) - should I just check "Skip Intel GFX", or something more?

How to use dedicated graphics (GT610M)? Is it "Use Nvidia ROM"?

And one more question - about installing FakeSMC - is it just to copy FakeSMC.kext or I should do a full install of some FakeSMC.pkg file?

 

Here are my CW configuration before these questions, with Use kernel Cache deselected:

 

post-1282511-0-35365900-1389601843_thumb.png

Share this post


Link to post
Share on other sites

Again, I didn't have any luck with this :( Again message of unknown CPU and kernel panic :( Is there anyone who manage to make Hackintosh work on DELL Inspiron 3420?? Is it possible at all??

Share this post


Link to post
Share on other sites

Kernel Panic or stuck at last message (IOBluetooth.....)

Last chameleon settings

Boot with -v dart=0

If doesn't work, try -v GraphicsEnabler=No dart=0

Not working again? -v GraphicsEnabler=No dart=0 -x

 

Good luck (and good hack)

Share this post


Link to post
Share on other sites

Is it possible that 10.9 won't boot into installation, and 10.8 could boot? I am thinking to make USB bootable drive in the same way, but with 10.8, is there a chance that 10.8 might work and 10.9 doesn't? :) I'll try tonight with some SMBios files that some people uploaded on forums while having the same error message about unknown CPU model on Ivy Bridge, and these boot codes, hope it will work :)

Share this post


Link to post
Share on other sites

I didn't have luck .... again :( My BIOS doesn't have options for disableing integrated graphics nor nVidia, neither option to specify how many MB I wanto to give to HD4000 :( I don't know how this is possible, but it is like that :( Now I'm downloading App Store untouched dmg 10.8.5 OS X from torrent, and will make bootable USB by the guide above again, hoping I'll have more luck with 10.8.5 than with 10.9 :)

 

 

I tried and, again, no success :(( I constantly get message "WARNING: IOPlatformPluginUtil : getCPUIDInfo: this is an unknown CPU model 0x3a", just like in my last post with bootload screenshot here :( Is there any kext or other way to go around this error message? I have Intel® Core™ i5-3210M CPU @ 2.50GHz (Ivy Bridge).

 

I tried now to edit SMBios.plist and inserted SMcputype to thevalue suggested for Ivy Bridge CPU, but no luck, again the same message. It seems that I must wait for iAtkos 10.9 release, hopping it will work :(

Share this post


Link to post
Share on other sites

I somehow managed to install 10.8.2 and everything seems to be working BUT internet. Is there any way to make dell wireless 1703 card work?? Any kext or pkg for it? :(

Share this post


Link to post
Share on other sites

Hello, unfortunately your wireless card does not work in OS X, you must purchase a half mini pci compatible and replace the original

Share this post


Link to post
Share on other sites

:((( and would it work if I would buy USB anthena for wireless? :(

 

I would like to buy this USB Wi-Fi, because it is small and wouldn't interfere with using my laptop. Sorry it is on Serbian, but lower on the page where specifications are located I think it is understandable enough :)http://www.tehnomanija.rs/adapteri_587/tp-link-bezicni-usb-adapter-tl-wn723n.html

 

I found this link about it http://www.osx86.net/files/file/744-tp-link-tl-wn723n-mountainlion/     saying that it is working on hackintosh, but I would like to ask one more time, here too, is this supported on Hackintosh? I have installed Mountain Lion (iAtkos ML2 - 10.8.2).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×