Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
medallo

laptop no arranca desde gpt

44 posts in this topic

Recommended Posts

hola.. requiero ayuda ya que mi laptop acer aspire 4752. solo arranca desde MBR.

Entonces la instalación del chameleon no lo lee y no arranca..  no se encuentra sistema operativo.

sólo me arranca desde instalador del usb por que está como MBR.

Alguna ayuda?

Gracias. :(

Share this post


Link to post
Share on other sites

has probado instalar el bootloader para tu disco ? :)  seguro que te aranca desde el disco :P

 

 

EDIT: quando instalas chameleon para el disco, el bootloader te genera un archivo .log , lo puedes leer y veras el problema que hay, o postea aqui

Share this post


Link to post
Share on other sites

has probado instalar el bootloader para tu disco ? :)  seguro que te aranca desde el disco :P

 

 

EDIT: quando instalas chameleon para el disco, el bootloader te genera un archivo .log , lo puedes leer y veras el problema que hay, o postea aqui

Gracias por tu ayuda..

Cuál bootloader.. te refieres Chameleon Wizard?

Share this post


Link to post
Share on other sites

He instalado tantos.. que clover, etc. que estoy mas que perdido..

Ese instalador ya lo tengo. y si no estoy mas desde que ya lo tenga es que ya lo he utilizado en algún momento. lo que sucede es que este equipo se rehusa a arrancar con particiones guid y solo arranca con MBR.. No deseo instalarlo con MBR creo que es mejor que quede con GUID. 

Sin embargo lo vuelvo a instalar y te coloco el .log

Share this post


Link to post
Share on other sites

hola.. este es el Chameleon_Installer_Log:

Chameleon installer log - Fri Nov 22 12:51:05 PST 2013
Installer version: 2.2svn 2266
======================================================
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Hac Book                499.8 GB   disk0s2
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *8.0 GB     disk1
   1:                  Apple_HFS USB                     8.0 GB     disk1s1
/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *7.8 GB     disk2
   1:                 DOS_FAT_32 NANDO                   7.8 GB     disk2s1
======================================================
Backup Chameleon files
======================================================
Clearing options...
======================================================
Running Standard postinstall script
Target volume = /Volumes/Hac Book on /dev/disk0s2
======================================================
Written boot0 to /dev/disk0.
Written boot1h to /dev/rdisk0s2.
Written boot to /Volumes/Hac Book on /dev/disk0s2.
======================================================
Preparing to check target disk for previous installations.
Going to check the EFI system partition also.
Mounting /dev/disk0s1 as /Volumes/EFI.
Checking disk0.
Nothing found that could cause any problems.
======================================================
Disk: /dev/rdisk0 geometry: 60801/255/63 [976773168 sectors]
Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
------------------------------------------------------------------------
 1: EE 1023 254  63 - 1023 254  63 [         1 -  976773167] <Unknown ID>
 2: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 3: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 4: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 
Setting /Volumes/Hac Book partition active.
======================================================
Standard script complete
======================================================
Added boot option: Legacy Logo=Yes
File Doesn't Exist, Will Create: //Extra/org.chameleon.Boot.plist
Theme Default installed
======================================================
Running Post postinstall script
Target volume = /Volumes/Hac Book
===============================================
Unmount all volumes named EFI
/private/tmp/PKInstallSandbox.FCpzkq/Scripts/org.chameleon.post.ezZiuD/UnMountEFIvolumes.sh: line 25: /private/tmp/PKInstallSandbox.FCpzkq/Scripts/org.chameleon.post.ezZiuD/InstallLog.sh: No such file or directory
/private/tmp/PKInstallSandbox.FCpzkq/Scripts/org.chameleon.post.ezZiuD/UnMountEFIvolumes.sh: line 26: /private/tmp/PKInstallSandbox.FCpzkq/Scripts/org.chameleon.post.ezZiuD/InstallLog.sh: No such file or directory
======================================================
Post postinstall script complete
 
 
*Este el org.chameleon.Boot.plist:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>   
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>No</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Timeout</key>
<string>2</string>
        <key>GenerateCStates</key>
        <string>Yes</string>
        <key>GeneratePStates</key>
        <string>Yes</string>
        <key>UseKernelCache</key>
        <string>Yes</string>
</dict>
</plist>
 
 
*Este el smbios.plist:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>SMfamily</key>
<string>MacBook Pro</string>
<key>SMproductname</key>
<string>MacBookPro8,1</string>
<key>SMboardproduct</key>
<string>Mac-94245B3640C91C81</string>
<key>SMserial</key>
<string>C02G1FMTDH2G</string>
<key>SMbiosversion</key>
<string>############.com</string>
</dict>
</plist>
 
 
 
Gracias.. 

Share this post


Link to post
Share on other sites

hombre, yo no entiendo porque tienes dos USB conectados a la hora de instalar el bootloader,

 

1. boot o system y quando estes en el escritorio disconect los usbs del ordenador

2. copie e lDownload    Chameleon-2.2svn-r2266.pkg.zip para el escritorio y instale para tu disco, disk0s2/ reboot

3. boot el system sin ninguno USB CONECTADO

4. si tienes el problema com boot 0 error, haga este procedimiento de copiar el boot1h para el disco

 

 

ok, this is the second option for install it, download binarios chameleon folder i386 :Download    i386_v2266.zip

1. open the folder i386 and copy boot1h for your USBInstaller.

2. boot from USBinstaller and go for utilities and open app Terminal

3. type diskutil list for identified your disk and partition where you installed of system ML = "(i.e: disk0s2)"

4. type diskutil unmount disk0s2

5. type cd /

6. type dd if=boot1h of=/dev/disk0s2 bs=4096

7. reboot

 

in steep 6 put your disk and partition "(i.e disk0s2 "), see your 

Share this post


Link to post
Share on other sites

He realizado tus dos recomendaciones y sigue el mismo problema : no se encuentra sistema operativo.

No muestra error de  boot0 , solo lo anterior,

sin embrago realize el segundo procedimento tambien e indico que la operación se realizo bien .. se grabaron xx bits en determinado tiempo.

La bios no lee GPT.. 

Una vez instale windows 8 y quedó el boot manager de windows cargado en las opciones de arranque de la bios. Este lo mande para abajo en las opciones de arranque.

este es el Chameleon_Installer_Log:

Chameleon installer log - Sun Nov 24 19:23:25 PST 2013
Installer version: 2.2svn 2266
======================================================
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Hack Book               499.8 GB   disk0s2
======================================================
Backup Chameleon files
Backup stage2 file /Volumes/Hack Book/boot to /Volumes/Hack Book/Chameleon.Backups/2013-11-24-19h23/boot
Backing up /Volumes/Hack Book/Extra folder to /Volumes/Hack Book/Chameleon.Backups/2013-11-24-19h23/Extra
======================================================
Clearing options...
======================================================
Running Standard postinstall script
Target volume = /Volumes/Hack Book on /dev/disk0s2
Target disk already has existing Chameleon stage 0 loader - boot0
======================================================
Stage 0 loader not written to /dev/disk0.
Written boot1h to /dev/rdisk0s2.
Written boot to /Volumes/Hack Book on /dev/disk0s2.
======================================================
Preparing to check target disk for previous installations.
Going to check the EFI system partition also.
Mounting /dev/disk0s1 as /Volumes/EFI.
Checking disk0.
Nothing found that could cause any problems.
======================================================
Disk: /dev/rdisk0 geometry: 60801/255/63 [976773168 sectors]
Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
------------------------------------------------------------------------
 1: EE 1023 254  63 - 1023 254  63 [         1 -  976773167] <Unknown ID>
 2: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 3: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 4: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 
Setting /Volumes/Hack Book partition active.
======================================================
Standard script complete
======================================================
======================================================
Running Post postinstall script
Target volume = /Volumes/Hack Book
===============================================
Unmount all volumes named EFI
/private/tmp/PKInstallSandbox.QtSNf6/Scripts/org.chameleon.post.J7g7Hy/UnMountEFIvolumes.sh: line 25: /private/tmp/PKInstallSandbox.QtSNf6/Scripts/org.chameleon.post.J7g7Hy/InstallLog.sh: No such file or directory
/private/tmp/PKInstallSandbox.QtSNf6/Scripts/org.chameleon.post.J7g7Hy/UnMountEFIvolumes.sh: line 26: /private/tmp/PKInstallSandbox.QtSNf6/Scripts/org.chameleon.post.J7g7Hy/InstallLog.sh: No such file or directory
======================================================
Post postinstall script complete

Share this post


Link to post
Share on other sites

he intentado crear 2 particiones una MBR para instalar el arranque del chameleon en ella y la otra GUID donde estaría el mac, pero en un sólo disco no puedo crear esas dos particiones , tiene que ser todo MBR o Todo GUID.

Asi que no se como proceder.. alguna sugerencia?

gracias..

Share this post


Link to post
Share on other sites

Si no puedes escribir al MBR de ninguna manera (dd dice copiado exitoso pero se restaura segundos después), probablemente estemos hablando del problema de MacOS con discos de sectores 4k. Tuve un disco 4k antes (aun lo uso para arrancar Windows) y era un verdadero dolor de cabeza para usar con MacOS como GPT y arranque legacy, pero esto fue hace un par de años atrás y desconozco si habrán solucionado este problema ya que compré otro disco para MacOS y me olvidé de todo este asunto por completo.

 

Bueno después de todo lo dicho y asumiendo que ninguna de las soluciones que hay dando vuelta por la internet te funcionan, como último recurso te diría que pruebes de convertir el disco a híbrido GPT/MBR, que es lo que hace Boot Camp para instalar Windows en Macs reales. De esta manera MacOS seguiría leyendo la tabla GPT y su instalador lo reconocería sin problemas, Windows/otros leerán el MBR, y dejará de tener un MBR protegido. Pero solo te lo recomendaría si no vas a tocar mas las particiones ya que va a tener 2 tablas distintas, pero los sectores de inicio de cada partición deben coincidir.

 

Si decides crear la tabla híbrida te podría ayudar con un paso a paso usando Gdisk, pero como te dije antes este es un último recurso, y no se realmente si tu problema se solucionaría convirtiendo el disco a híbrido. Es solo una idea mas que probé y no recuerdo bien pero creo había funcionado con mi disco 4k.

Share this post


Link to post
Share on other sites

Si no puedes escribir al MBR de ninguna manera (dd dice copiado exitoso pero se restaura segundos después), probablemente estemos hablando del problema de MacOS con discos de sectores 4k. Tuve un disco 4k antes (aun lo uso para arrancar Windows) y era un verdadero dolor de cabeza para usar con MacOS como GPT y arranque legacy, pero esto fue hace un par de años atrás y desconozco si habrán solucionado este problema ya que compré otro disco para MacOS y me olvidé de todo este asunto por completo.

 

Bueno después de todo lo dicho y asumiendo que ninguna de las soluciones que hay dando vuelta por la internet te funcionan, como último recurso te diría que pruebes de convertir el disco a híbrido GPT/MBR, que es lo que hace Boot Camp para instalar Windows en Macs reales. De esta manera MacOS seguiría leyendo la tabla GPT y su instalador lo reconocería sin problemas, Windows/otros leerán el MBR, y dejará de tener un MBR protegido. Pero solo te lo recomendaría si no vas a tocar mas las particiones ya que va a tener 2 tablas distintas, pero los sectores de inicio de cada partición deben coincidir.

 

Si decides crear la tabla híbrida te podría ayudar con un paso a paso usando Gdisk, pero como te dije antes este es un último recurso, y no se realmente si tu problema se solucionaría convirtiendo el disco a híbrido. Es solo una idea mas que probé y no recuerdo bien pero creo había funcionado con mi disco 4k.

Hola.. No creo que sea problema de discos por sectores de 4K, ya que probado 4 y todos los mismo.

pero no es que no pueda grabar en MBR o Que se borre después, Al contrario graba y la laptop lee bien en MBR, el problema es con la partición GPT que la laptop se niega a leerla.

Se puede inclusive instalar todo pero en MBR y no hay problema arranca y todo bien , pero deseo que sea mas vanilla la laptop.

Sólo deseo mac en la laptop, asi que creo vendría bien el método hibrido MBR/GPT.. Pero no se ni por donde empezar para esto.. cualquier ayuda  agradezco..

Share this post


Link to post
Share on other sites

A ver… Hay varios malentendidos que complican lo que quieres decir:

 

sólo me arranca desde instalador del usb por que está como MBR.
Se puede inclusive instalar todo pero en MBR y no hay problema arranca y todo bien

Cual es cierto al final? Puedes o no arrancar desde tu disco rígido?

 

 

he intentado crear 2 particiones una MBR para instalar el arranque del chameleon en ella y la otra GUID donde estaría el mac

MBR y GUID (GPT) son tablas de particiones, no particiones en sí. Y como expliqué antes, si deseas ambas tablas estamos hablando de un disco híbrido, que es un tema delicado y el ultimo recurso para quien no puede arrancar desde el disco rígido.

 

 

el problema es con la partición GPT que la laptop se niega a leerla

Supongo que estas hablando de la partición "EFI" de tu disco GPT, cierto? La partición EFI no es usada durante el proceso de arranque por MBR, solo el arranque UEFI la requiere.

 

 

Ahora, sumando todas las pistas de tus posts, supongo que lo que quieres es instalar Chameleon en la partición EFI (convertida en una partición normal FAT32) de tu disco GPT para que arranque desde esa partición en lugar de la partición donde instalaste OSX. En ese caso el proceso es similar al sugerido por iFIRE pero con unos pasos mas.

Share this post


Link to post
Share on other sites

Amigo medallo, Por favor no es necesario hacer citas completas de comentarios inmediatamente anteriores al tuyo. Se sobreentiende que respondes a ese comentario. Y así contribuímos a no saturar el servidor con citas una y otra vez. Lo importante son los comentarios y aportes nuevos. Espero que entiendas. Gracias. Saludos.

Share this post


Link to post
Share on other sites
Puede ser una buena opción.. creo.. Lo que requiero es poder instal de la manera mejor y mas natural. pero si lo instalamos de esta manera aunque sea fat32, sigue siendo GPT y creo que no la leerá.

Tienes confundidos los conceptos. GPT/GUID y MBR son tablas de particiones. FAT32, HFS+, NTFS son formatos de particiones.

 

Entonces lo que quieres es mantener tu disco como GPT/GUID y arrancar en modo legacy. Correcto?

 

Pero, estas seguro que tu laptop no es capaz de arrancar en UEFI? Podrías ver en la bios si hay alguna opción que diga "Legacy", "EFI boot", "secure boot" o similar? Porque si puede (google dice que si) entonces Clover seria tu solución ideal. Te permitiría tener el sistema mas vanilla posible en un hackintosh, solo debes saber como instalarlo y configurarlo.

Share this post


Link to post
Share on other sites

No veo ninguna opción relacionada con legacy o UEFI - muy pobre la bios, pero es de esperar - así que nos quedaría primero probar instalando Clover en la partición EFI con boot0af/ss en el sector MBR, y si no funciona convertimos el disco a híbrido.

 

Antes que nada me gustaría ver en detalle como esta particionado tu disco, así que descarga DarwinDumper y ejecutalo con las opciones "boot loader detect & boot sectors" y las 2 que le siguen. Selecciona archive as zip desde la ultima opción y sube aquí el zip resultante.

 

Una vez que vea bien con que estamos lidiando nos pondremos manos a la obra.

Share this post


Link to post
Share on other sites

Ok, manos a la obra entonces. Empecemos probando con Clover. Asumiendo que tienes un pendrive de backup con Chameleon para arrancar el sistema, sigue estos pasos a ver si logramos que Clover arranque al menos:

 

1- Formatea la partición EFI desde un Terminal:

diskutil list (anota el "identifier" de la partición EFI, probablemente disk0s1)
sudo newfs_msdos -v EFI -F 32 /dev/rdiskXsY (aquí va el identifier anterior)

2- Instala Clover con las siguientes opciones:

 

post-158318-0-36719600-1385690694_thumb.png

 

3- Copia tu DSDT/SSDT (si es que usas alguno) en la carpeta /EFI/CLOVER/ACPI/patched

4- Edita el config.plist localizado en EFI/CLOVER/config.plist con lo que creas necesario para tu sistema. Puedes dejar esto para mas tarde si quieres, una vez que confirmes que arranca.

5- Reinicia

 

Si ves la pantalla de Clover, entonces vamos por buen camino y solo quedaría configurar bien las preferencias para tu sistema. Si no aparece Clover, arranca con el pendrive y vuelve a instalarlo como en el paso 2 pero esta vez seleccionando boot0ss en lugar de boot0af.

 

Si sigue sin funcionar habrá que convertir el disco a híbrido, pero espero no sea necesario…

 

Share this post


Link to post
Share on other sites

hola..

Los instalé de las dos maneras y lo mismo .. sistema operativo no encontrado.

Ahora en la instalación apareció obtener xcode y como no tengo internet no se instaló esto.

Tambien en las opciones de clover que mencionas en Drivers64UEFI las seleccione todas.

Al ver que no arrancaba con las dos opciones que comentas, reinstalé clover pero ahora seleccionando la primera opción: Instalación para placas base UEFI y después de reiniciar se queda el cursor titilando " __ " y de ahí no pasa pero NO muestra lo de siempre " sistema operativo no encontrado".

Coloque el DSDT.aml que tengo en la carpeta que cuentas.

Gracias por todo.. ahi vamos... :wink_anim:

Share this post


Link to post
Share on other sites

Entonces no hay manera de arrancar legacy con Chameleon o Clover ni UEFI con Clover… Pero parece que al menos intenta en UEFI…

 

Lo del Xcode debe ser porque necesita una herramienta de desarrollo para alguna tarea, pero no se cual será.

 

El haber seleccionado todos los drivers UEFI esta mal, hay un par que no deben usarse juntos. Intenta instalando solo OsxAptioFix y EmuVariable y si sigues teniendo el mismo problema entonces no queda otra que convertir el disco en híbrido.

Share this post


Link to post
Share on other sites

después de reiniciar se queda el cursor titilando " __ " 

 

 puede se que la particion no esta activa, prueba activar la particion EFI

 

En la terminal escribe: sudo -s

passw; pon tu contraseña

 

./fdisk440 -e /dev/rdisk0

 

p         +enter          <-----> (print a list on screen) 

f 1        +enter        <-----> (makes partition 1 active) see your Partition

w          +enter       <-----> (write to disk)

y            +enter      <-----> (yes)

reboot    +enter

Share this post


Link to post
Share on other sites

Hola este es el resultado.


 

bash-3.2# fdisk440 -e /dev/rdisk0

fdisk440: could not open MBR file /usr/standalone/i386/boot0: No such file or directory

Enter 'help' for information

fdisk: 1> p

Disk: /dev/rdisk0 geometry: 60801/255/63 [976773168 sectors]

Offset: 0 Signature: 0xAA55

         Starting       Ending

 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]

------------------------------------------------------------------------

 1: EE 1023 254  63 - 1023 254  63 [         1 -  976773167] GPT         

 2: 00    0   0   0 -    0   0   0 [         0 -          0] unused      

 3: 00    0   0   0 -    0   0   0 [         0 -          0] unused      

 4: 00    0   0   0 -    0   0   0 [         0 -          0] unused      

fdisk: 1> f 1

Partition 1 marked active.

fdisk:*1> w

Device could not be accessed exclusively.

A reboot will be needed for changes to take effect. OK? [n] y

Writing MBR at offset 0.

fdisk: 1> reboot

Invalid command 'reboot'.  Try 'help'.

fdisk: 1> 

 

Cerre la terminal ya que no se reinició y reinicie el equipo.

Resultado:

No se encuentra sistema operativo.o sea que volvió a lo anterior.

 

Seguire con la otra propuesta a ver que sucede.

Share this post


Link to post
Share on other sites
Y qué esperas que suceda? Cuál sistema operativo tiene que cargar? Porque por arte de magia NO va a aparecer un S.O. de la nada.

 

Ese disco aparece claramente como "SIN USO" (unused), es decir que NO tiene particiones definidas, o NO están formateadas, únicamente se nota la EFI (EE).

 

Me parece que eres TU quien esta haciendo este caso más difícil de lo es. Comentario tras comentario, y cita tras cita, es lo único que demuestras. Sin progreso.

 

Por cierto, he instalado OS X y Windows XP-7 (GPT/MBR en el mismo disco) infinidades de veces, he utilizado tres (3) discos distintos de 4k (western digital), y otras marcas como seagate e hitachi, y nunca he tenido problemas para instalar sobre esquema GPT arrancando con Chameleon.

 

P.D. Podrías elaborarte una firma con las ESPECIFICACIONES de esa portátil? Y por favor también un link para saber cuál controladora SATA-AHCI lleva esa placa base? Es para facilitar las cosas y poderte brindar un mejor soporte. Gracias.

Edited by juanerson
Es la última llamada de atención con el tema de las citas contiguas.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×