Jump to content

nForce 4.


8 posts in this topic

Recommended Posts

Hi guys, thanks for reading my post!!

 

I am running a AMD Athlon 64 3800 +, KN1 Sli lite Motherboard, Radeon X550 PCI e Graphics Card, with 1.5GB/ram.

 

I am having problems with a number of things, including, Networking, sound and a low resolution... Can any of you guys help me, (im a newbie at the whole hackintosh thing)

 

The Network and Sound (Which I belive used the AC97 Codec) Are Built onto the motherboard.

 

Thanks in advance,

 

Shadow. :)

Link to comment
Share on other sites

Well, you have some unusual devices. It is doubtful you will get them working.

 

For sound, try this guide - be sure to read and follow the Appendix: http://forum.insanelymac.com/index.php?showtopic=18642

 

For Network - you will need to try to do something similar to the sound guide:

Go to Windows -> Device Manager and find your ethernet device. Get Properties on it. Click on the Details tab and get the vendor id and device id.

 

- Make a string of the form: "0x" + (device id) + (vendor id). Be sure to get the order correct - device then vendor. It should look something like this: 0x436211AB

 

- In Terminal (in Utilities folder), edit this file:
sudo nano /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon.kext/Contents/Info.plist

 

Change the string "0x436211AB" to your new string created above.

 

Control-O to save. Control-X to exit

- Delete the following files:

/System/Library/Extensions.mkext

/System/Library/Extensions.kextcache

- Open Disk Utility (in Utilites folder) and repair permissions on your OSX partition

 

- Reboot
Link to comment
Share on other sites

-- sigh --

 

Under "Network Adapters", it says "Realtek RTL8139/810x Family Fast Ethernet NIC". What the hell do you think that is?

 

Under "Sound, video and game controllers", it says "Realtek AC'97 Audio". What the hell do you think that is?

 

The guide also said to go to "System devices", find "Microsoft UAA Bus Driver For High Definition Audio". You didn't expand that one at all.

Link to comment
Share on other sites

  • 3 weeks later...

Shadow110 and everyone else runnnig an ECS KN1 SLI Lite mobo (like me).

 

I've got sound and network working. MacVidia 1.0.8 also installs and working but is kind of weird so I left it out on my last install.

 

Anyway I've got 10.4.6 installed and running (after about 10 attempts!). I also tried Jas 10.4.7 but it didn't work!

 

I'm running KN1 SLI Lite with AMD64 X2 4600+

 

For sound follow these instructions: http://wiki.osx86project.org/wiki/index.php/Audio. You need to go all the way to step 14. The vendor and device IDs are: Vendor:10de and Device:0059 so use 0x005910de.

I've tried a bunch of other techniques but this one is the only one that worked. I get stereo sound and works great.

 

For network follow these instructions http://forum.insanelymac.com/index.php?sho...cedeth_nock_fix and use forcedeth_nock_fixed.zip instead of the one from the instructions. Download it here http://forum.insanelymac.com/index.php?sho..._fix&st=180 posted by letni (thank you). I also attached it just in case.

 

Note that I encountered weird things trying to get the network working. After messing around with different solutions, somehow the network port of the mobo decided to stop working (nic leds would not turn on even when the network cable is plugged in and that caused Windows XP to not find the NIC card! To fix this I had to reflash the BIOS and it worked again! BIOS version=1.1e).

 

I also had to use cpus=1 kernel option to overcome the stuttering effect but so far all is going good.

 

Good luck and report back.

forcedeth_nock_fixed.zip

Link to comment
Share on other sites

 Share

×
×
  • Create New...