Jump to content

Acer 5715Z, DSDT, SSDT and EIST


2 posts in this topic

Recommended Posts

Hello to everyone.

For past few days I'm trying to install SL on this notebook, and I think that I'm close to that, sort of.

First let me explain what have I done so far.

Original SL 10.6.3 restored to USB, booted with ##### from everybody know where.

Installed as usual, updated everything,  copied in /E/E/ FakeSMC, ACPIMonitor, ElliottForceLegacyRTC, EvOreboot, NullCPUPowerManagement, installed Chameleon 2.2svn (svn-r2266), rebooted from HDD only with "-v arch=i386" and it worked, not well, but for the first time, just fine.

Problems with trackpad and keyboard, so I installed  AppleACPIPS2Nub and ApplePS2Controller to E/E/, but every reboot, without rebuilding the caches, stopped working. So, I copied to S/L/E/ and right now it's ok. Actually, E/E/ is empty.

Only kexts that I installed in S/L/E/ are:

FakeSMC, v3.3.1 with X3100 and IntelCPUMonitor plugins

BCM5722D under plugins of IONetworkingFamily

VoodooHDA 0.2.1




Problem is, EIST don't work. I tried first with copying unmodified DSDT with all 7 SSDT in /Extra, bdmesg is full of information about the system, cpu, memory, everything is recognized, but with MSR Tools multiplier is 3 and speed is 1600, and with HW Monitor speed is only 800 MHz. HW Monitor  actually see temps from both cores, GPU and HDD, voltages, speed and multiplier. 


I tried fixing DSDT, with only DTGP, T_x rename and SMBUS patches from DSDT Editor, and I see in kernel.log that message "** AppleSMBusPCI::start failed to get acpi path for provider" is gone, so patching is working, but…


So, right now, I can't think of anything else. Somebody might have some new idea, it doesn't matter if it's crazy, using hammer or chainsaw, but might work. This isn't something sooo important, but nonetheless I would like to finish this little experiment, and than proceed with Lion, and maybe, just maybe with ML. Wireless isn't important for now, if everything else would and should work, I'm thinking of buying some compatible mini pcie. 


Here is all tables, smbios and chameleon plist, if somebody is eager to see where the problem is.


Thanks for watching, reading, commenting, and, why not - helping??


Link to comment
Share on other sites

MBP 5,1 with a DSDT compiled by artur-pt  and only P and C-states. bdmesg is continuing that is added only two states, but actually EIST is working. HW Monitor clearly show changes from 6x all the way to 12x, CPU Voltages also. MSR Tools shows all that plus 3x, but I think that this has to do with throttling FSB, not the multiplier.

I steel don't get it why this change, because IORegistryExplorer still list "com.apple.driver.AppleIntelMeromProfile". Only theory would be that MacBook3,1 has somewhat bad speedstep, and in MBP5,1 its fixed. Somebody will understand this, right now to tired to think.


I was curious, so I compiled another DSDT, only with DTGP, T_x rename and SMBUS patches, copied every SSDT in extra, but keeping MBP5,1 smbios, and actually, EIST is working. Obviously, something with MB3,1 isn't good. So, thanks again.

This topic is SOLVED.

Link to comment
Share on other sites


  • Create New...