Jump to content

Missing network adaptor (Gigabyte H87-D3H)


1 post in this topic

Recommended Posts

Hi everyone, 

Hoping to get some assistance with this... weird situation... basically, I create the ML USB Bootable installer and pass -x -v GraphicsEnabler=No to boot and install. This goes fine without any hitches. 

Once the installation is done, I boot into the new OS instance for the first time using -x -v and the OS boots up. Everything is fine at this point, with the network card being recognized. I can even surf on Safari.

As a first step in finalizing the installation, I insert FakeSMC.kext at this point and restart the machine. Normally on the boot after inserting FakeSMC.kext, I use -v ncpi=0x3000. The OS boots fine but at this point, when I enter, the NIC seems to longer be detected (either you no longer see it in the network connections or its there but "cannot communicate") and in its place is something which seems to be a PCI modem.

If I boot with -x again, the NIC gets detected and all is fine as long as I safe boot. Unfortunately, that's not really a good spot to be in. Would anyone have any idea what might be causing this behaviour?

System specs:
Gigabyte H87-D3H motherboard
Intel 4670 I5 processor
Samsung 840 Evo SSD
G-Skill 1600 C9 8gb ram kit
Asus GTX 650 Ti Boost gfx
Lite-On DVD Writer

Things I've tried:
Wasn't sure (Still am not) if it was the FakeSMC but have tried 2 different versions (6.09 and 5.3.820) with no change. Tried playing around with ncpi = 0x2000 and PCIRootID with no visible effect. Have also completed the post installation till the bootloader stage and tried AppleIntelE1000e.kext but nothing seems to make the network card come back.

Link to comment
Share on other sites


  • Create New...