Jump to content
InsanelyMac Forum
Sign in to follow this  
cjhmdm

[Solved] Chameleon driving me insane

Recommended Posts

Hello, I'm having a serious issue with chameleon that is pretty much driving me insane. For some reason, every time I power on my machine, or reboot, chameleon is remembering a command I manually typed a while back. Basically, when going to the boot prompt screen (where you type commands), it always has "-f" typed in, and I don't know how to get rid of it.

 

Normally, this wouldn't be such a huge issue but since I'm running off a raid0 set, I have to use the kernel cache, so any time I boot or reboot i have to sit there and manually remove the "-f" from the boot prompt otherwise I'll get the mach_kernel not found error.

 

Also, just to make it clear, this isn't an issue with my using a raid0 set, and has nothing to do with it at all because it's been happening since I first installed mavericks GM last week on a single disk, and had to enter "-f" one time due to a kext issue I was having (before I even considered using raid).

 

At any rate, if someone could please chime in and let me know how to resolve this, I would be eternally grateful as I want nothing more than to be able to use the QuietBoot option and turn my system on -- or reboot -- without having to sit there and manually remove the -f every time.

 

Huge thanks in advance.

Share this post


Link to post
Share on other sites
Advertisement

The issue had nothing to do with org.chameleon.boot.plist. AS it happens, I found the solution shortly after posting this thread even though I'd spent hours beforehand searching. I essentially had to do what amounts to "sudo nvram -d boot-args" though a bit more involved since I'm running on raid0. But the outcome was essentially the same, nvram had cached the typed in "-f" boot argument so I had to clear it out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Cool! Do you have a link? Googled and didn't see anything yet.   Never mind... you're quick! I just noticed you updated it on the 1st page THANKS!!!!!!
    • I resolved the problem. Just set this coding in your config.plist:   "
      <key>KextsToPatch</key>
              <array>
                  <dict>
                      <key>Comment</key>
                      <string>USB 10.13.4+ by PMHeart</string>
                      <key>Disabled</key>
                      <false/>
                      <key>Find</key>
                      <data>
                      g32UDw+DlwQAAA==
                      </data>
                      <key>InfoPlistPatch</key>
                      <false/>
                      <key>MatchOS</key>
                      <string>10.13.x</string>
                      <key>Name</key>
                      <string>com.apple.driver.usb.AppleUSBXHCI</string>
                      <key>Replace</key>
                      <data>
                      g32UD5CQkJCQkA==
                      </data>
                  </dict>
              </array>     "
    • New Web Driver - 387.10.10.10.30.107 for 10.13.4 build 17E202
    • I guess having pre{max-height: 500px;overflow: auto;} in CSS was too much for IPS Devs' tast.  Until an admin has hands on this, you still can use stylish plugin to accomplish it.     In fact, it is pretty easy than it appears - Just apply a simple click on the codebox (it will highlight it), then 'delete' key.
    • all the possible frequencyes i have added seems to work fine at the moment, i have added a lot of different frequencyes to support better all kinds of professional applications, inclunding strange sampling rates and goes from 8khz up to 176.4 khz, unfortunately 192 khz does not seems to work even on cards which should support it like the audigy rx, but other frequencyes just works fine and at the moment i have tested only the sound blaster audigy rx and the audigy sb0090 (1st gen audigy) and i can confirm that all the frequencyes from 8khz up to 176.4 khz does work on that card, so i think that such frequencyes should work on all the audigy 2, 2sz, 4 cards as well, tomorrow i will test with my sound blaster live! cards and i will let you know, but here are also some photos (pro tip: use cmd + alt/opton + 4 and then press space to make a screenshot of a single window):


×