Jump to content

xps studio 8100 ethernet and RTL8188s wlan kext not working (Solved!)


1 post in this topic

Recommended Posts

I've got XPS studio 8100 installed with a few of pandora and ##### ML kexts. However, Ethernet and Wlan is not working.

On osx 10.6.8 ethernet is using AppleBCM5751Ethernet.kext:

Type: Ethernet Controller
Bus: PCI
Vendor ID: 0x14e4
Device ID: 0x1692
Subsystem Vendor ID: 0x1028
Subsystem ID: 0x040d
Revision ID: 0x0001
Link Width: x1
BSD name: en0
Kext name: AppleBCM5751Ethernet.kext
Location: /System/Library/Extensions/AppleBCM5751Ethernet.kext
Version: 2.1.0d21

10.6.8 Wlan is working with RTL8192SUs.kext and Realtek Wireless Utilities:
RTL8188S WLAN Adapter :

BSD Name: en1
Product ID: 0x8172
Vendor ID: 0x0bda (Realtek Semiconductor Corp.)
Version: 2.00
Serial Number: 00e04c000001
Speed: Up to 480 Mb/sec
Manufacturer: Manufacturer Realtek
Location ID: 0x1d170000 / 3
Current Available (mA): 500
Current Required (mA): 500

Please help me find the correct kexts for Mavericks

Edit2: Problem Solved:
1. Realtek 8188SU driver 10.8 work with Maverick 10.9 can be downloaded from Realtek website:

2. Broadcom BCM57780 Driver for 10.9 Maverick working well atm with the link below


Link to comment
Share on other sites


  • Create New...