Jump to content
krumurk

Triple boot (Solucionado)

6 posts in this topic

Recommended Posts

Tengo 3 HDD cada uno con un SO diferente. El primero tiene ML 10.8.2, el segundo tiene W7 y el tercero ubuntu.

Cuando arranco el ordenador al ser el primero el ML me arranca el chamaleon y tengo visibles tanto mac os x, como w7 pero el HDD de ubuntu no me sale por ningun lado. Como puedo hacer para que desde el chamaleon me muestre el disco duro de ubuntu y pueda arrancar sin problemas?

 

Cuando hice las instalaciones de los SO solo conectaba 1 disco para que no me tocare el arranque del resto. Cada uno fue instalado de forma solitaria sin ningun otro disco duro conectado.

 

Con el comando diskutil list desde terminal me sale el siguiente esquema:

post-1105510-0-15649100-1381872513_thumb.png

Share this post


Link to post
Share on other sites
Advertisement

Hola:


Hace un tiempo atrás, en un disco duro hice tres particiones en GUID.


Instalé Mac, Windows y Debian.


 


Me pasó lo mismo que a ti.


Lo solucioné instalando GPTSync para Mac.


No se si te servirá también a ti, pero si quieres probar…


 


Un saludo.


 


gptsync-0.2.pkg.zip


Share this post


Link to post
Share on other sites

Pues nada no me funciono. Pero aun asi lo he conseguido arreglar de otra manera. He entrado en ubuntu y abro un terminal:

 

Escribo df y pulso enter. Me sale una lista de los discos con sus particiones, la que cuenta es la primera entrada la que sale montada con la "/" esta es la que hace falta. En mi caso creo que era /dev/sda3

 

Escribo en terminal sudo grub-install -f /dev/sda3 se remplaza "/dev/sda3" por la entrada correcta de tu sistema la que esta montada con la "/" y damos enter. Nos pedira la contraseña de root, la escribimos y pulsamos enter.

 

Cierras el terminal y reinicias el sistema y entras en mac os x y reinstalas el chamaleon de nuevo en el disco de mac.

 

Reinicias la maquina y cuando salga el chamaleon saldra la opcion para arrancar ubuntu.

Share this post


Link to post
Share on other sites

Pues nada no me funciono. Pero aun asi lo he conseguido arreglar de otra manera. He entrado en ubuntu y abro un terminal:

 

Escribo df y pulso enter. Me sale una lista de los discos con sus particiones, la que cuenta es la primera entrada la que sale montada con la "/" esta es la que hace falta. En mi caso creo que era /dev/sda3

 

Escribo en terminal sudo grub-install -f /dev/sda3 se remplaza "/dev/sda3" por la entrada correcta de tu sistema la que esta montada con la "/" y damos enter. Nos pedira la contraseña de root, la escribimos y pulsamos enter.

 

Cierras el terminal y reinicias el sistema y entras en mac os x y reinstalas el chamaleon de nuevo en el disco de mac.

 

Reinicias la maquina y cuando salga el chamaleon saldra la opcion para arrancar ubuntu.

Yo hasta ahora arrancaba el triple boot (4 en realidad, tengo un ML de pruebas) desde el grub, pero cada vez que actualiza el kernel había que volver a editar el grub teniendo que borrar las entradas falsas de macox y era un rollo, así que probaré a tu manera.

 

Gracias por el aporte.

 

Una pregunta, puedes cambiar el orden de arranque, o el sistema predeterminado?

Share this post


Link to post
Share on other sites

Me respondo a mí mismo.

No hay problemas en poner por defecto el SO que tú quieras.

Lo único que el arranque de Linux es un poco lento, pero no llega a ser molesto.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×