Jump to content

Stuck on Still waiting for root device, AppleACPIPlatform to blame?

1 post in this topic

Recommended Posts

Hi all,

Just finished my first build a little while ago, however I've run into a few issues.


My Hardware:
Processor: Intel 4770k Haswell
Motherboard: Z87-D3HP
Graphics Card: EVGA 01G-P4-3655-KR
SSD + HDD, however only SSD is plugged in currently.

No optical drive.


My first error was a dependency issue that was resolved by installing "AppleACPIPPlatform Rollback/10.8.1 Rollback."

I then received the "[ PCI Configuration Begin ]" error, which I resolved by replacing "AppleACPIPlatform.kext" and "IOPCIFamily.kext".

However, now I'm stuck at "Still Waiting On Root Device" error. OS installed on SSD. Tried unplugging HDD, no luck. SSD is plugged into a SATA 6gb/s port. Tried with rd=disk0s2 (where OS is), but that hasn't resolved the issue.

I was able to load the desktop using "npci=0x2000 pci=no -x -v" prior to installing the AppleACPIPlatform.kext and IOPCIFamily.kext, so I'm wondering/thinking that those caused the issue.

Any ideas?

Link to comment
Share on other sites


  • Create New...