Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Mavericks Disk Utility Rearranged Partitions

5 posts in this topic

Recommended Posts

I can't believe that I'm the only one so far to experience this.  I'm posting this as a warning.
I wanted a fresh installation of Mavericks, so I used Maverick's installer Disk Utility to erase my current Mountain Lion partition.  For some reason, "Core Storage" kicked in and rearranged the partitions on my hard drive.  All I did was select the partition "testOSX" and "erase".
So, I tried to re-partition, but the partition pop-up was greyed out.  I had to use GPARTED to remove all of the existing partitions before I could use Disk Utility to re-partition the drive.
I thought this was a fluke, so I tried a second time and the problem repeated.
As a test, I proceeded anyway to install Mavericks and Chameleon to "testOSX" but Chameleon got confused and couldn't boot it.
Cleaning up and partitioning/erasing with the Disk Utility in Mountain Lion gave a successful booting installation of Mavericks.
Partitions - Before and After "Erasing"


The "types" associated with the partitions changed as well.
3 TB Hitachi - Media
disk0s1 - EFI (hidden)
testOSX - Mac OS Extended (Journaled)
TM - Mac OS Extended (Journaled)
testOSX - Logical Volume Group
testOSX - Logical Partition
diskOs1 - EFI (hidden)
testOSX - Core Storage Physical Volume (hidden)
Boot OS X - Apple Boot Partition (hidden)
TM - Mac OS Extended (Journaled)



Share this post

Link to post
Share on other sites

What can I say, this is probably why my WD my book studio II reset itself after I installled Mavericks GM. All my partitions on that drive lost and it's even reproducible. Bad one! 


To clarify, I installed Mavericks GM on the internal drive on my Mac mini, after a restart I noticed my external drive had been...ehum...tampered with.

Share this post

Link to post
Share on other sites

Do you have a Fusion drive setup, or are you using your EFI partition to store the bootloader's /Extra directory?

I've seen similar behaviors when a EFI partition is formatted as HFS. Disk Utility displays it like seen above, but I've never seen a partition shown before the EFI partition.


Anyhow, the fact that you have a Boot OS X helper partition indicates that your system thinks it has a RAID or Fusion setup. Odd, indeed.

Do the following Terminal commands reveal anything?:

diskutil cs list


diskutil appleRAID list




Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.