Jump to content

Failing to install Mountain Lion on ASRock Z77 Extreme4

5 posts in this topic

Recommended Posts

I know loads of users has been successful in installing Mountain Lion on this hardware (See my signature), however not me!


Whatever I try in whatever way I never manage to boot up a GUI (except maybe two times in safe mode),

the framebuffer is left uninitialized and the boot up procedure is left hanging at;


[iOBluetoothHCIController][start] -- completed


First of all I updated my EFI firmware to 2.70 (cstate writeable patched by Samisnake).


Second, I unplugged my Radeon HD 5770 Video Adapter and all other harddrives not needed for this installation.


Third, I cleared the CMOS completely and changed ONLY these settings in the EFI UI:

  • Advanced
    • North Bridge Configuration
      • Share memory - 64MB
      • Render Standby - Disabled
    • Storage Configuration
      • Hard Disk S.M.A.R.T - Enabled
      • SATA2_2 (The port which my target harddrive is plugged in on)
        • Hot Plug - Disabled
    • Intel® Rapid Start Technology
      • Intel® Rapid Start Technology - Disabled
    • Super IO Configuration
      • Serial Port - Disabled 

I managed to get all installers I've tried to boot with the flags -v -f PCIRootUID=0 and the installation goes well and all,

however I can't manage to boot up my system after installation.


At first I tried with a ##### built installer, which failed to boot my final installation.

Then I tried an installer built with myHack 3.2 Beta 8, which not only failed to boot my installation but also failed to install Chameleon.


So after 10 hours of fiddling with those two installers, researching and going at again (think I might've reinstalled ML about 30 times now)

I decided to roll my own Vanilla ML installation flash drive, just to be sure EXACTLY what I'm including and what might cause it.


So I followed this guide with a few minor differences;

  • In step 2.C.4 I went with a MacMini6,1 SMBios default as recommended on various threads with similar hardware.
  • Since I've already got working CPU Power Management from the patched EFI firmware I didn't bother using NullCPUPowerManagement.kext

  • I'm using Chameleon v2.2svn 2247 


Now, I don't know the policy on this board for posting SMBios configs and such so i posted both org.chameleon.Boot.plist and SMBios.plist here.


Trying to boot without the Kernel Cache (-f gives me);

Kext com.apple.iokit.IOAcceleratorFamily - library kext com.apple.iokit.IOGraphicFamily not found.
Can't load kext com.apple.driver.AppleIntelHD4000Graphics - failed to resolve library dependencies.
Kext com.apple.driver.AppleIntelHD4000Graphics failed to load (0xdc00800e).
Failed to load kext com.apple.driver.AppleIntelHD4000Graphics (error 0xdc00800e).
Couldn't alloc class "IntelAccelerator"
Kext com.apple.driver.AppleHDAController - library kext com.apple.iokit.IOGraphicFamily not found.
Can't load kext com.apple.driver.AppleHDAController - failed to resolve library dependencies.
Kext com.apple.driver.AppleHDAController failed to load (0xdc00800e).
Failed to load kext com.apple.driver.AppleHDAController (error 0xdc00800e).
Couldn't alloc class "AppleHDAController"
Edited by Pontus Carlsson
Link to comment
Share on other sites


After installation of OS X, before reboot open up terminal and type in:


“ cd /Volumes/YOUR PARTITION's NAME/System/Library/Extensions”

- "sudo mkdir Temp"

- "sudo mv AppleIntelHD* AppleIntelSNB* Temp"


and reboot.


Alternatively you can boot up in safe mode and remove all intel kexts manually.


For HD4000 to be working install chameleon and kexts from the attachment below


HD4000 & Chameleon.zip

Link to comment
Share on other sites

Actually, I can't even boot up in Safe Mode I'm afraid.

But I did boot up the installer and used the Terminal from there to execute the commands you posted,

I then installed both AppleIntelSNBGraphicsFB and AppleIntelFramebufferCapri, also I installed the chameleon version you posted.


Now, trying to boot with -v -f PCIRootUID=0 gives;

OSMetaClass: Kext com.apple.driver.AppleIntelSNBGraphicsFB class HDCPCtrl is a duplicate;kext com.apple.driver.AppleIntelFramebufferCapri already has a class by that name.
Kext com.apple.driver.AppleIntelSNBGraphicsFB start failed (result 0xdc00400a).
Kext com.apple.driver.AppleIntelSNBGraphicsFB failed to load (0xdc008017).
Failed to load kext com.apple.driver.AppleIntelSNBGraphicsFB (error 0xdc008017).
Link to comment
Share on other sites

No need to continue this topic now, my goal was to get my Radeon HD 5770 (As specified in my signature) to run properly,

and right now I've made more progress with this than with the the HD 4000.


And by progress I mean I've successfully enter the system in Safe Mode. However, I'm having issues with the AMDRadeonAccelerator now instead.

Should I open a new topic for this or can I continue here?

Link to comment
Share on other sites

Hey I might have some info that would help. Try using this AtiPorts=? how ever many ports you have. AtiConfig= your cards name. Also I did manage to get this fully functioning with a amd 7950. I am not too proud of the way I did it and really it don't even matter how I did it but it is done. 




Shared memory Auto

Igpu disabled

Render disabled

Deep render disabled


Also might want to have the fbrotate app. 

Link to comment
Share on other sites


  • Create New...