Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
MOCKBA80

ML 10.8.5 on ASROCK H87M PRO4

2 posts in this topic

Recommended Posts

I am having no luck with ASRock H87M PRO4 + i5-4670K and fresh ML 10.8.5 retail-install. Computer reboots right after I am done reading kexts... Tried 10.8.4 with patched kernel with the same result... Tried to feed pretty much any keys to boot loader... Something is telling me that I don't have BIOS setup properly because same drives (10.8.4 patched and 10.8.5) boot in my LGA775 box.

 

Any ideas/hints/success stories?

 

Thanks

Share this post


Link to post
Share on other sites
I managed to boot 10.8.4 patched with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] last night. I cannot get ALC 892 to work and for some reason I cannot use my GT 220 PCIe video card and for some strange reason I could only boot with -v -f together with ncpi=0x3000 PCIRootUID=0 dart=0 in Boot.plist.

 

I did pretty much retail install (using mac to build a drive) + [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] + svn chameleon (2265 I believe) + [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] after [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]. Apparently it is all about kernel and

deleting GenericUSBXHCI.kext from /System/Library/Extensions and thus last step is the key.

Now, once I got 10.8.4 to boot I tried the same kernel on 10.8.5, but I am getting exception in AppleTyMCEDriver.kext (that looks the same between 10.8.4 and 10.8.5) so it gotta be something in IOPCIFamily, so I rolled them back to 10.8.1 with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], but was getting same "couldn't find symbol _acpi_idle_kernel". 

 

 

I would try to use IOPCIFamily from 10.8.4 to at least may be get on chip GPU accelerated with 10.8.5, but I really need my Nvidia PCIe working and I don't understand why it is not working for me - video card was working fine with retail installs in other boards and with ASROCK I go into [PCI Configuration] and then screen either goes black or it just hangs there and GraphicsEnabler=Yes/No don't seem to have any effect. Any ideas what I might be doing wrong?

 

There is no way to disable on chip GPU in ASROCK BIOS (BIOS only allows to enable PCIe GPU) and I suspect that this might be the reason.

 

Regarding ALC892... Judging by reports for ASROCK 77 boards to get AppleHDA working would most likely require DSDT... I never learned how to patch DSDT myself, so any help would be appreciated... Otherwise, did anybody try Voodoo yet?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×