Jump to content

Acer Aspire 5630-6288 no sound on OS X 10.6.0


2 posts in this topic

Recommended Posts

Hi everyone;


First of all, thanks for this great forum that helped us learn and understand about Mac OS for our PC's.


Second; I want to brieflt describe my experience with Snow Leopard on my Acer Aspire 5630-6288 using Empire EFI. I did install Snow leopard two times and then I used chameleon 2.0 RC3, PC EFI 10.5, FakeSMC v2,


First Time;



- During the installation I needed to use an external display.

- After the installation I needed to install PS2 Fix for the trackpad and for the keyboard.

- I used VoodooBattery kext to show the Battery Percentage.

- GMA 950 kext to fix the Display.

- Sound worked using VoodooHDA kext

- The 3945abg wireless mini-pci never worked, I then tried the atheros AR5BXB63 mini pci card and didn't work either.

- Ethernet controller did show power because both lights (green and orange) were on but unfortunately I was unable to connect to internet.


Second Time;


- I did the same procedure during installation but with the difference that I replace the wifi card with a ATHEROS AR5B91.

- After installation I needed to fix the keyboard, the trackpad and the display again (Used the same kexts used on the 1st installation.

- The airport Logo was there but didn't find my router and didn't wanted to connect by adding the router manually. I installed AtherosFix Kext and nothing. After that I did a trick of placing a tape in PIN #20 and it WORKED!!! It worked Flawlessly in an WPA2 security, Found the router immediately.

- Ethernet controller with the same issue as before.

- Tried sleepenabler kext but didn't work.


And here is my problem;


I don't have sound during the second installation even I installed VoodooHDA kext used for the first installation. I tried different kexts for of VoodooHDA, tried one for the ALC883 and nothing, and obviously the AppleHDA kext OOB didn't work. I used kext helper b7 to install the kexts.




Any idea that what caused that? The difference between installations was that during the second installation I add some kexts that the chameleon 2.0 offered.


Is it correct to just throw the kexts to thrash if you don't needed or wanted? If not, then how I can remove the undesire ones and how to rebuild the cache from the old installations made and didn't help?


Is there any sleepenable kext that work on SL? I tried 2 of them, but when I select the SLEEP option the PC freezes and I need to reboot.


Thanks and I will help in anything I can with you as well.



Link to comment
Share on other sites


Install the latest Chameleon version. Download here: http://www.insanelymac.com/forum/files/file/59-chameleon-22-svn/

Download the VoodooHDA for SL here: http://www.projectosx.com/forum/index.php?showtopic=355

Read and understand about common VoodooHDA problems here: http://olarila.com/forum/viewtopic.php?f=28&t=454&sid=db3a5af7b5d5f5c38497d03ca5008794

Don't forget remove AppleHDA or install AppleHDADisabler before install VoodooHDA.

Use Kext Wizard to install kexts, is the best app for this job.

First solve this audio problem after power manager problem.

Any problem comeback reply.

Link to comment
Share on other sites


  • Create New...