Jump to content
InsanelyMac Forum
Sign in to follow this  
jamiethemorris

GPT Corrupted, fixed with gdisk, now will only boot from USB

Recommended Posts

I have a Dell Mini 10v dual-booting Arch Linux and SL 10.6.7. The setup was working perfectly fine, but for some reason I stupidly decided to make it "better" by downloading and running gptsync. What happened after I did that is it would only boot into arch. I opened gparted and saw that the boot flag was on the efi partition, so I moved it to my os x install partition. After that, Chameleon started up, But the only partitions it showed were "windows fat32" and "archlinux." i tried booting from chameleon on my thumb drive and got the same result. I opened gdisk and found that the gpt and mbr were showing completely different partition maps. I built a fresh gpt from the mbr and then re-converted it to hybrid mbr, then I saw the efi partition was reading as "windows basic data" so I changed it to ef00. Now I can boot into OS X or Linux via my thumb drive, but when I try to boot off the disk itself I get "non-system disk." OS X disk utility shows the efi partition now, which is weird. Chameleon also shows the efi partitiona and it still says "windows fat32." How can I fix this?

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×