Jump to content

Kernel Panic


6 posts in this topic

Recommended Posts


Shuttle SN21G5 [NF4]

A64 3200+

1 gb Corsair XMS PC3500

Sapphire [ATI] X1600XT


60gb - IDE - Windows [31gb] - OSX - [25gb]

80gb - SATA - Media [45gb] - * [30gb]



I've installed Acronis Disk Suite, and did the os slector. It all boots fine, does the while scrolling thing, and then I get a kernel panic.



panic(cpu 0 caller 0x0019CFFC): commpage no match on last routine

Debugger called: <panic>

Backtrace, Format - Frame : Return Address (4 potential args on stack)

0x6d4bee0 : 0x128aea (0x3b9dcc 0x6d4bf04 0x130c94 0x0)

0x6d4bf20 : 0x19cffc (0x3bf434 0x6d4bf7c 0x13000 0x0)

0x6d4bfb0 : 0x196b69 (0x0 0xffffffff 0x4431f8 0x49b800) Backtrace terminated-invalid frame pointer 0x0


Kernel version:

Darwin Kernel Version 8.4.1: Tue Jan 3 18:23:53 PST 2006; root:xnu-792.7.90.obj~1/RELEASE_I386


What i've done:

I looked all over the place for my os x disk, which I cannot find for the life of me. I think someone threw it away ( :) ) so I downloaded 'Ultimate Boot CD' after seeing a post of saying that they fixed it that way. I have no clue what to go into after it boots. After searching I found my OSX cd, I tried a method I saw on here:


-Booting OSX cd


-Type: cp /match_kernel /volumes/*





When I entered that, I got bash:

"No such file or directory"


As of now, Im fresh out of ideas. I've been on here for a few hours searching on here. Please help! :D

Link to comment
Share on other sites

cp /mach_kernel "/Volumes/(name-of-your-OSX-partition)/"


Use the quotes if your OSX partition name has a space in it.


Will do. I think I see my error. I put match, you put mach. :poster_oops: I'll post back if it works. Thanks.

Link to comment
Share on other sites



I booted up the cd and typed "cp /mach_kernel /volumes/OSX" and it booted. BUT after the white scrolling text it went to the screen where I would get the kernel panic, but it kept going. After that, it went to a black screen and I could see a cursor, but nothing happened after that. It just sat there with a black screen and a cursor.


What should I do?

Link to comment
Share on other sites

I reinstalled it with the X11 patch and did the cp /mach_kernel /volumes/OSX command and im golden now.

I think it was the reinstall. X11 is a windowing environment for Unix and has nothing to do with OSX operation. And you'll probably never, ever use X11.

Link to comment
Share on other sites


  • Create New...