Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
cloudcover

Need help - GTX 660 card not working at 2560x1440 resolution

4 posts in this topic

Recommended Posts

Hi -

I've gone through the process of installing OS X 10.8.3 on a system with a GA-77X-UD5H motherboard WITHOUT my external video card. I then set GraphicsEnabler=No, powered down the system, installed my GTX 660 video card, connected my Dell U2713HM monitor to it through the DVI connection, and rebooted. I didn't install any Nvidia drivers because I'd read that OS X 10.8.3 already has support for Nvidia 660 built in.

The splash screen for the Gigabyte BIOS looks fine and clean, and so does the white screen with the gray apple logo on it. But when it comes to the login screen, the image is super fuzzy and noisy. I can still make out the login screen, but it's really "buzzy" (don't know how best to describe it).

If I go to "About this Mac..." it shows that it's recognized the GTX 660 video card with 2048Mb memory.  If I go into Display Preferences, it shows that it's running at the monitor's native resolution of 2560x1440 and at it's native 60Hz refresh rate.  If I change the resolution and choose a scaled resolution that's 1920 x 1080, everything looks super clean and fine. But if I choose anything with a horizontal resolution of 1440 (my display's native resolution is 2560x1440) it gets super fuzzy and noisy again.

I've tried using both the HDMI and DVI connections - no difference. And I've tried using another PCI slot- no difference.  Tried another U2713HM monitor (I have two) and same problem.

Would really appreciate some help as this is a major sticking point. Not sure why it would work fine at lower resolutions but not at my monitor's native resolution.  Do I just have a bad video card or is there some configuration issue that I need to change?  Thanks in advance.

Share this post


Link to post
Share on other sites

Hi,

 

I have a GA-Z77X-UD5H as well, and a month ago bought a U2713HM.

 

When I first plugged it in and hooked it up I used my existing DVI cable that was previously driving my 20" LCD and had the same "fuzzy"/"buzzy" picture at 2560x, but it was perfectly sharp and nice at 1920 and lower.

 

I fixed it by swapping to the DVI cable that Dell had included in the box - which was a fatter cable, and I have since learned was Dual-Link DVI which allows for the needed additional bandwidth that the high 2560x1440 resolution requires. http://en.wikipedia.org/wiki/Digital_Visual_Interface#Dual-link_DVI

 

Give the cable a try, hopefully that's all it is.

 

Tom

Share this post


Link to post
Share on other sites

Thanks, yes I came to that same result with the help of someone else and it did, indeed, solve my problem.  Part of the difficulty in my case was that Dell had shipped both monitors with single link DVI cables instead.   :mad: The monitors were refurbished and I assume whomever was packing them up just grabbed the wrong cables.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×