Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

10.8.4 and ALC888 / ALC1200

3 posts in this topic

Recommended Posts

I need a hint to get my audio controller working.
At the moment I am not able to get anything working.
After editing DSDT "Intel High Definition Audio" and "Layout-ID: 12" is listed in System Profiler.
Then I installed AppleHDA.kext for ALC888. I tried many of them, but nothing.
No output or input devices are listed in System Profiler or Settings.
I tried both versions of this codec.
I do not not, what to do now. Patching AppleHDA on my own would be a heavy task.
You can find the ioreg and codec information and my DSDTs (modified and original) in the attachments.

I hope, you can help me smile_osx.png

PS: I always get sound assertions in AppleHDAController at line 816 and at line 483. I also get them with the pure vanilla AppleHDA.kext
I am using Clover to boot OS X.

codec information.zip


Share this post

Link to post
Share on other sites


Already see here? http://www.insanelym...or-alc1200-108/




Yes, i tried it. It seems, that the codec is not recognized. I even checked the verbs in ConfigData. They are almost identical with my patched ones, but there are some exceptions.

I am not sure, maybe it is deeper problem? I hear pop sound during boot, so the audio controller is powered. 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.