Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  

Installed iATKOS S3 v2 on separate partition, now rest of HDD shows as unallocated space

5 posts in this topic

Recommended Posts

:help: Hello, I'm new to the Hackintosh scene, but not new to dual booting and tinkering in general. I've dual booted Windows XP, 7, 8 RP, and some Linux distros at various points in the past. My hardware is dated, but capable. Hardware:

OC'd Intel E2160 CPU @2.4GHz (for about 5 years now with no issues)

Abit IP-35e MB

6GB of GSkill DDR2 (not OC'd)

MSI GTX460 v2

OCZ Vertex 2 SSD (60GB)

WD 640GB SATA HDD (3 partitions - Win 7, Mac, Storage)


My primary OS is/was... Windows 7 Ultimate 64bit. I had a dual boot set up with Windows 8 RP, but I never used 8 as I don't like it. I got to reading again about the Hackintosh scene a couple of days ago and realized that people have had success with my hardware. I initially tried installing iATKOS S3 v2 in VMWare Workstation 8. I got to the stage of installation where I was formatting the virtual disk, but it was taking a very long time, so I decided to just blow away the VM and try a native install of iATKOS S3 v2 onto my Windows 8 partition. I had already formatted my 8 partition from within 7 before I tried the VMWare method. I was storing the virtual disk on the old 8 partition (appx. 50GB). I don't know if this is relevant, but I'm trying to be thorough, I opened EasyBCD and deleted the entry for 8.


Next I burned and booted iATKOS. I went with the defaults expecting that it would probably not install successfully, but hoping that it may. I figured I would go back and try again, researching the options more thoroughly, if it failed to install. I was surprised when it said that it installed successfully. I then rebooted and was taken to what I assume is the Chameleon boot screen. It shows my Mac partition that I installed to, and it shows my SSD, which isn't bootable (it just has games on it). OS X will not boot. I haven't done too much troubleshooting on that. I decided that I would work on that tomorrow. In the meantime, I wanted to get my Win 7 bootable. I tried this, but when I got to "list partition" it only shows the Mac partition. I then read that I probably just need to repair the Windows installation. I tried the automated repair option, but it said that it could not repair it. It said the system volume was corrupted. Then I read somewhere else that I may just need to mark the Windows 7 partition "active". So I booted GParted. I figured this would be an easy fix. Unfortunately, this is where things have gotten very bad. GParted only shows my 50GB Mac partition on the HDD. The remainder of the disk is shown as "unallocated". I'm worried that I've lost all of my data. I did not format anything other than the Mac (old Win 8) partition. I didn't perform any operations on the other partitions. I've got GParted scanning for file systems on the drive right now for data recovery. I'm not too well versed on disks. I'm hoping it's something that can be repaired like a table or something. The data should still be there. I do have a partial backup, but I wasn't able to backup the entire drive because my backup drive is too small. I don't think there is anything on the drive that would be disastrous if lost, but I would REALLY like to be able to recover.


If anyone has any ideas or suggestions, I'll give it a try. GParted has been scanning for probably 30 minutes now. I have to go to bed because I work tomorrow, so I guess I'll let GParted run overnight. Thanks in advance. :wallbash:

Share this post

Link to post
Share on other sites



I suspect you selected to create 2 partitions on the drive with Disk Utility. This explains the lost partition, as it deletes the partition entries and creates the new partitions. The correct approach was to select the second partition and erase ("format" in Windows terms) to MacOS Extended Journaled. Hopefully your data are all there at the "unallocated" space and you can recover them. Before you start, save the state of the recovery. This helps if you have to interrupt the process, eg to change destination disk because it is full. In such case, take a note at which folder you stopped. Then close the recovery application, switch off your computer and replace disks as necessary. Start the recovery application again, choose the disk and load the saved state. In a few seconds you should be able to continue restoring to the new disk without scanning again! I can feel your pain. I just finished recovering data from a PC that wasn't properly shutdown and the disk was screwed. I finally can begin reinstalling everything...


As for MacOS X 10.6 you probably have to reinstall it choosing carefully the options related to your hardware (button customize at installer). In worst case, try Kaylway's 10.5.2 version (Leopard). It always succeeds in almost every hardware. Too bad that you cannot upgrade to 10.5.8 (it will cancel any custom hacks and MacOS won't boot again). You could also create a small partition to install Kalyway 10.5.2 temporarily in order to use the terminal to make 10.6 work on the other partition! I have done that for an Atom-based Acer Aspire One. It worked perfectly up to 10.6.7 with all upgrades without any problem. After every combo upgrade I had to replace the customized mach_kernel file in root directory in order to boot again. But when I did the mistake to upgrade to 10.6.8 it was screwed, and I didn't want to go all that trouble again, so I deleted the Mac partition and expanded Windows to take all the available disk space (for that purpose I had installed Windows on the first partition and Mac on the second, as I recommend doing, unless you want MacOS your main OS. In that case you can later delete the Windows partition and expand MacOS).


I hope that helps. Good luck with your recovery.

Share this post

Link to post
Share on other sites
The correct approach was to select the second partition and erase ("format" in Windows terms) to MacOS Extended Journaled.

This is exactly what I did, so I'm a little perplexed as to how my drive got into this shape.


I've been attempting recovery with the Testdisk utility on the GParted Live CD for most of the evening. I believe I have made a little progress as I now see two NTFS partitions in GParted. I also still see 199GB of unallocated space between the two NTFS partitions, but I'm hopeful since I am at least seeing two NTFS partitions. I don't know how this happened to begin with, but at this point I'm to the point where I don't care anymore. IF I decide to make another attempt at OS X, I will definitely be using a separate physical drive. I think my current partition table/disk issue is outside the scope of the OSx86 project. I was initially hoping this had happened to someone else here and there would be an easy fix, but I'm starting to think something else went wrong and may have caused this. I appreciate your response, but I will likely take this issue to another community that is more tailored to data recovery and HDD issues. If I attempt OS X again, I'll be back here if I have any problems though. :)

Share this post

Link to post
Share on other sites

I always partion with disk utility ,more than 3. >GUID

1 would be fat 32

2 would be Mac

3 would be linux

I install Windows first and Mac last so at boot , f8 > I select OS

Share this post

Link to post
Share on other sites

I would rather scan the whole disk for data, not just a specific partition. After having finished my own recovery, I tried to reinstall Windows, but the disk was so badly screwed that it was detected in the BIOS (thanks God) but Windows installer could not find any! I then used Digiwiz MiniPE. This is a Windows XP custom live CD-ROM with many recovery tools etc. I found one that claimed to restore partition data. After restoring the partition table, the disk was visible, but could not of course load Windows. At least I could now wipe it and install Windows again. If you are lucky, you could use a similar utility to make the Windows partition visible again, and assuming it has no other problem, you could even boot into Windows without any repair or with only startup repair. Of course I wouldn't try anything before I had finished restoring the data, just in case.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.