Jump to content

Problems with Realtek AC97 Soundcard- PLEASE HELP


8 posts in this topic

Recommended Posts

First of all sorry for my bad english.


I have problems with my Realtek ALC850 (AC97)

onboard soundcard on a Asus P4P800E Deluxe mainboard.

After i installed 10.4.4 or 10.4.5 (same DVD) the "AppleAC97Audio.kext" and "AppleAC97AudioIntelICH.kext" can not be loaded and i have no sound.

If i install another Version of OSX86 (10.4.3 only english) the soundcard runs and i have no problems.

I tried to copy the "AppleAC97Audio.kext" from the 10.4.3 system to the 10.4.5 and changed

the permissions but its still not running.

I also tried to patch the "original" AppleAC97Audio.kext after installation with this description:


but i cant move in this directory:


It doesnt exist.


Please help me!

I tried it hours for hours and i´m going crazy.

Maybe someone can patch a "AppleAC97Audio.kext" for my soundcard.

The ID´s: VEN_8086DEV_24D5SUBSYS_812A1043REV_0

So the PNP ID is 0x24D58086 correct???

Link to comment
Share on other sites

  • 3 weeks later...

Sorry for the late answer!


I patched the


not the


that doesnt exist under 10.4.4 or 10.4.5.

I did it with this description:




Link to comment
Share on other sites

Could you please show me exactly what lines you edited. I have the same mobo but could not find the lines as you stated earlier. Please help.


You said: I patched the



What exactly did you patch, is my question.



This is my info:


Device ID: PCI/VEN_8086DEV_24D5UBSYS_81841043REV_0

Realtek AC97 Audio

General Information :

Manufacturer : ASUSTeK Computer Inc


Codec Information :

AC'97 support : Yes

Manufacturer : Avance Logic

Model : ALC850



Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...
  • 2 months later...

Sorry for the late answer but here it is:


Step 1 - Start Terminal)

Load up Terminal. This is found in the Applications/Utilities folder.


Step 2 - login as root)

Get root access. (do "sudo -s" to stay secure)

(*NOTE: If you haven't already, copy the AppleAC97Audio.kext using this

command as root: "cp -R <path>AppleAC97Audio.kext /System/Library/Extensions/" )


Step 3 - change to directory)

cd /System/Library/Extensions/AppleAC97AudioIntelICH.kext/Contents


Step 4 - chmod Info.plist)

chmod 644 Info.plist


Step 5 - edit Info.plist)

nano Info.plist


Step 6 - insert your ID)

NOTE: If you are not using an Nvidia or Intel chipset, do not edit this file, in fact what is said below only works for nforce products.

Scroll down until you see "<key>NVIDIA AC97 Audio</key>" You will see a part below it that says <string> **Other ids** </string>. Enter yours in so it looks like <string> **other ids** 0x005910de</string> (in case you didn't notice, it's 0x then your four character vendorID then 4 character devID, so for example if your vendorID=0059 and your devID=10de so you would add 0x005910de)

All the "vendor" keys are below the <key>IOPCIPrimaryMatch</key>, I infer.


Realtek ALC850 (AC97) = 0x24d58086


Step 7 - Quit editor)

Press Ctrl+O to save it and Ctrl+X to quit nano.


Step 8)

cd /System/Library/Extensions/AppleAC97AudioIntelICH.kext/Contents


Step 9)

chown -R root:wheel /System/Library/Extensions

chmod -R 755 /System/Library/Extensions/AppleAC97AudioIntelICH.kext


Step 10)

cd /System/Library/Extensions/AppleAC97Audio.kext/Contents/PlugIns/

cd /System/Library/Extensions/

kextload AppleAC97AudioIntelICH.kext


Step 11)

Clean your extensions cache:

rm /System/Library/Extensions.kextcache

kextcache -k /System/Library/Extensions



I hope this will help you.

Link to comment
Share on other sites


  • Create New...