Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  

[HELP] ML on ARCTIC MC001 ATOM D525 NM10 ATI 5430

2 posts in this topic

Recommended Posts

Hi all,


I recently bought an Arctic MC001 barebone, added 4gb of RAM an Agility 120GB SSD and a BD drive. By now i'm running crappy W7 with XBMC because I tried to install ML with ##### method without luck (after loading kext the system reboots without letting me even get to the installation prompt)

I set AHCI in BIOS and tried to boot with combinations (- v -x GraphicEnabler y/n PCIRoot=0/1 etc...)

For the Mobility 5430 i found this:


that should work even for mine but before I have to reach the installation prompt..

I know that Atoms are not supported anymore since 10.6.2 and I don't know if that's the cue but I'd love to use even 10.6 instead of W7.. so if you could help me in any possible ways I would really appreciate..



Thanks in advance



Share this post

Link to post
Share on other sites



I recently installed an Artic MC001 with Mountain Lion with help of Iatkos ML2. Updated to 10.8.3. and took a lot of hours to enable QE via HDMI.

Flashed the latest Bios and extracted a DSDT File. The most important thing is the Atom capable kernel on other Mountain distributions. 

I'm still trying to enable HDMI audio, but I did not find to time to solve this in my dsdt File. Maybe my dsdt.aml will fix your installation problem.


Working: ATI 5430 HDMI ok VGA Not

Sound ok with patched Applehda.kext

SDcard Reader running out of the box


USB3 with PXHCD.kext

Wlan ok with RT2870USBWirelessDriver.kext

Ethernet ok witrh RealtekRTL81xx.kext




Still not working


HDMI Audio out



10.8.4 (did not give a try)


I would like to enable speedstep to get rid of NullCPUPowerManagement.orig.kext.


Try to use my ATIConfig from org.chameleon.Boot.plist:



<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<key>Boot Graphics</key>
<key>Kernel Flags</key>
<string>AtiConfig=Shrike npci=0x2000</string>
<key>Legacy Logo</key>
<key>Quiet Boot</key>
I was really a long time ago. I hope I did not forget anything...


Extentions in System-Libtrary.zip

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.