Jump to content

Mid to High End PC, cannot install ML or any distro.


37 posts in this topic

Recommended Posts

For two days i'm trying to install Mountain Lion on my computer without luck. I keep getting panic errors, or don't manage to boot from the USB, or other things like.


I managed to install it under VirtualBox in the end, to create a bootable usb disk under Mac. But once again i get another errors and to be honest i'm about to let go of all this.


So, let me begin with my configuration:

AsRock Extreme 4 Motherboard - no bios modifications-

Intel i5 3570k Cpu

16 Gb DDR3 1600mhz ocz dominator

Asus DirectCu2 Gtx 680

Kingston 120 gb SSD to install on

Hama 16Gb USB 3 Memory Stick


What i did so far with no success:

1. I created a simple CD with Chameleon bootloader, trying to install it from dvd without luck because of the bigger image size that won't fit on a simple dvd.

If anyone has some some idea on how to shrink the image to fit on one dvd would be awesome.


2. I downloaded iAtkos ML3 UEFI boot, managed to install it, no boot after restart. I tried using all the boot flags i've found around without luck. It kept freezing at Apple Logo, or stuck in the same place with the spinning wheel. With verbose i kept getting the error about power management.


3. I downloaded iAtkos ML2, but i don't manage to make the usb bootable. I've installed it under virtualbox, but when i try to use disk utility to create my USB stick, i keep getting kernel panic when i insert my usb stick or trying to work with it in any way.


The way i'd like to go for now is iAtkos ml2, but i don't manage to boot it up from the usb. I recorded the .dmg image to usb using TransMac, PowerISO and no luck.

The best way is thru virtualbox, but i keep getting kernel panic because of IOUSBFamily.kext and all the related kext about it.


I'm not a complete noob when it comes to using a PC, but when it comes to Mac i am:)


Any help would be greately apreciated.

Link to comment
Share on other sites

http://www.asrock.co... Extreme4&o=All at the bottom of the page?

Mine is z77 not p67 as you found.


My main problem is that if i could manage to get the USB stick working without KP, everything would be oke. I tried installing other kext using #####, but i get install failed with everything.


I think i'm gonna stick with windows. I'm out of ideas...i tried everything i found in google and i always get some sort of error:|

Link to comment
Share on other sites

I'm reinstalling it on virtualbox to try pandora. The tutorials from above require to download a new copy and it goes with 40-80kb/sec max download. It takes forever.


But still, is it so hard to install this thing? I managed to install some time ago 10.2 without all these problems.


Is there nothing to do with the USB KP? Nothing at all? That would solve all the problems...

Link to comment
Share on other sites

It turns out that Pandora really is helpfull. But i had to make some changes before using it. So, until now:


I installed VirtualBox Expansion Pack to enable legacy Usb. This let me use my usb port withour KP and i used Pandora to create a fully bootable usb stick. But i'm getting stuck in the last minute of installation because of the appleCpuPowerManagement kext. I'm trying to use NullPower kext now using transmac. I'll update soon.

Link to comment
Share on other sites

I passed the USB problems and i did install the latest FakeSMC driver. No luck:(

Patched Bios

Now using AppleCPUPowerManagement kext

Reinstalling right now.


I'll update soon


It would be really great if someone could tell me the command to enter in Terminal to replace faulty kext from usb to hdd without reinstalling it everytime.

Link to comment
Share on other sites

Now i can't even install it. It just freezes.


{censored} all this...i wasted enough time. Windows i love you! :))))

If you have VB and a working osx with it, you can use that VB for installing an osx to a raw disk and modifying it inside VB.



Please be extra careful, you may mess up your working system including booting.

Link to comment
Share on other sites

So...i can't give up. I won't sleep at night if i do :D


I reinstalled a clean Windows system in a different hdd, leaving my SSD for OSX only. I'm installing right now a new copy of iAtkos ML2 on a virtual machine and i'll go step by step with this tutorial: http://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-mountain-lion-chameleon-dsdt-for-beginners/


Any advice is welcomed:)


I'll update soon.

Link to comment
Share on other sites

You mean on the bios or in the VB?


Can i do dual-boot from this situation?

I mean: Windows on one hdd and osx in the other? (if i manage to get it done), oh and btw, patched bios turned off my usb during windows install, so no mouse and no kb. I had to flash stock bios again.

Link to comment
Share on other sites

In the bios. You can dual boot very good with to seperate HDD's. But when you are going to install Mountain Lion it's a little bit easier to unplug the Windows HDD. You don't have to but then you will have some very easy CMD work to do. I don't think the bios is going to be a critical problem.

Link to comment
Share on other sites

That's what i was thinking too. I will disconnect the windows hdd while installing osx. And i will set onboard vram to 64 too, thanks for the tip.


One more thing. i have a downloaded copy of the mountain lion dvd (retail). It's a .dmg file. To create a restore usb like the tutorial is saying, i have to find Install OsX.app in Applications, but i don't understand how to install it from the dvd. Any advice?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...