Jump to content

Black Screen with Clover


3 posts in this topic

Recommended Posts

Hello !


My new PC has an UEFI, so I decided to install Clover, and I have a big problem : when I use Clover to boot into my OS X partition, in verbiose mode, everything looks fine, there is no errors, until the log screen should appear : instead, the screen turns off and nothing happens. The only thing who change what happens is to turn on the display fix in DSDT options : then, when I try to boot, a kernel panic occurs, "Unable to find driver for this platform:"ACPI"".


Here is my specs :


Asus N76VZ laptop

Intel Core i7 3630QM

Intel HD4000 Graphics + NVidia Geforce 650M

Aptio UEFI

RAM : 8Go

Mountain Lion 10.8.3


What did I done before installing Clover :


- I created an USB install key with ML and chameleon, it boots fine.

- I installed OS X on my 2nd HDD, and I haven't install chameleon which is not recognized by UEFI. I boot from the USB key each time.

- I created an USB install key with ML but without chameleon, I restore it with disk utility into a 8Go partition of my second HDD.

- I made a vanilla install of ML in my first HDD, with only the 6 necessary kext to make OS X usable (FakeSMC, NullCPUPowerManagement, IntelCPUMonitor, VoodooPS2Controller, ACPIPS2Nub and GenericUSBXHCI).


Then, I installed Clover in my first HDD just with the installer.


Clover Drivers :


I try with all the UEFI drivers, then with only VboxHfs-64.efi, OsxFatBinaryDrv-64.efi, and OsxAptioFixDrv-64.efi (UEFI), then with all UEFI & 64 drivers, but there is always the same result.

I try with the DSDT I used with chameleon but this is the same result.


Results :


- When I try to boot on the OS X of my second HDD, there is a kernel panic with VoodooHDA (whereas there isn't kernel panic with chameleon)

- When I try to boot on the OS X of my second HDD, or on the ML installer of my USB key or the one of my HDD, there is a black screen (screen is off), and if I turn Display fix on into DSDT options of Clover, there is a kernel panic : Unable to find driver for this platform:"ACPI"


Note : I haven't update my UEFI, do you think it may solve the problem ?


Thanks for your answers !

Link to comment
Share on other sites

Thanks ! It's working really fine !


Now I have to turn GraphicsInjector off in Clover options (definitively) and to enable Graphics acceleration. I'm searching for that, but if you had an advice for me, it would be nice ^_^



EDIT : Ok I found how to do =D


There were a few lines to add in the config.plist of Clover :


For disabling GraphicsInjector :





For enabling Graphics Acceleration (only for my laptop ?) :





Would you like I send my config.plist for giving an example ? (I am not permitted to upload this kind of file, so I'll send it with mediafire or another host)


A big thanks for your help !

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...