Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Kosta88

Very weird sleep/wake problems

4 posts in this topic

Recommended Posts

There is some weird stuff going on here on my Hack. Problems are with waking from the sleep.

 

My hack will normally go to sleep but when I try to wake it, I have to wake it twice... first keyboard press wakes the fans and apparently the computer, but there is no connectivity, for instance Teamviewer doesn't come online. Also display remains black. The 2nd keyboard press wakes up the screen and also the internet connection.

 

This is however a really bad situation, as I need to be able to wake up my computer remotely, and I don't have a chance of pressing the keyboard key... note that waking up twice, actually puts a computer to sleep again, which is also very weird!

 

All to me known fixes are installed, AppleRTC, Restart Fix in Chameleon, and I have a PCIX NIC now, RT 8111e.

 

All seems to be working fine now, except this one single problem!! I tried changing the power options in BIOS, activating and deactivating various options, but to no avail. Also on the internal mainboard ethernet I experience the same behavior, so it's not the NIC!

 

Any recommendations, idea, anything would be much appreciated!

 

Thanks

Share this post


Link to post
Share on other sites

Yep, tried that. No change. The worst thing, things are even worse for some reason than before - I can't find out if it's the BIOS settings, but I can't even wake the computer any more. It goes to sleep and that's it.

 

Can someone tell me what the specific settings should be at, my motherboard taken into consideration:

- Speedstep

- C1E

- C3/C6 Report

- C-Package Support

 

These are all in the power settings.

 

Is there anything else in BIOS what might impact how the computer behaves when it comes to sleep with OSX? The whole thing is completely fine in Windows, last time I checked. I even removed the Plextor DVDR for now, as it was doing weird stuff.

Share this post


Link to post
Share on other sites

So, I wanted to update this: I found the reason why it broke.

I used the tutorial to enter my GPU into DSDT here: http://rampagedev.wo...d-into-a-dsdt/.

Even with his help, this apparently broke the sleep function.

 

What I did to confirm:

 

I tested now without DSDT + GraphicsEnabler=Yes + Darkwake=0, and all was again well as before. So I did a bit more extensive testing, and this is what happens:

With the DSDT edit from above, GE=No, DW=0 not checked: computer sleeps OK, pressing a button wake up the fans, but no picture, nor internet present (for instance, Teamviewer doesn’t come online)

Remove DSDT (or the edit), GE=Yes, DW=0 not checked: sleeps OK, pressing a button wakes up fans, but I have to press a button again to wake up the screen. Wake-on-Lan is also unusable in this configuration, as the internet also doesn’t come up.

And finally, with removed DSDT, GE=Yes, DW=0 checked: sleeps OK, wakes up OK, also screen turns on fine, also via wake-on-lan function.

 

Gonna be testing this in the coming days, but apparently using DSDT on my configuration is just unnecessary.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×