Jump to content
nuis

Digitus DN-7042 USB Wifi Dongle (RTL8188CUS) on 10.8.3 Problems

3 posts in this topic

Recommended Posts

Hello,

I am coming from this thread http://www.insanelym...hackintoshable/ and

got osx 10.8.3 running on my Laptop Asus N56VZ with the image file from http://ukrainianipho...&st=20&start=20 (mentioned in the thread)

:

My internal wifi card (Atheros AR9485) is not working, so i decided to buy a usb wifi dongle: Digitus DN-7042 (based on Realtek chipset RTL8188CUS)

I installed drivers from here: http://www.realtek.c...&Downloads=true (RTL8188CUS for 10.8)

 

Now first: it is somehow "half" working. I can see available networks in the wireless utility, but fail to manually connect (see no other option at all).

There is also no wifi icon and network preferences says cable not plugged when selecting the wifi dongle!?

 

I made some screenshots. The kext files that appear in extensions folder after install are somehow strangely named RTL8192CU8.kext and RTL8192SU8.kext (not matching the name of the chipset)

 

Maybe someone can give me a hint or point in some direction what to try next maybe.

If i can provide more info i would be glad to do (just not very familiar how osx handles driver stuff and where to look)

 

Thanks for any input

post-1153720-0-02292700-1365782968_thumb.jpg

post-1153720-0-75408800-1365782982_thumb.jpg

post-1153720-0-52208800-1365782998_thumb.jpg

Share this post


Link to post
Share on other sites
Advertisement

your problem can be app Realtek, not the kexts, search for a old app Realtek or other version, for example 10.7

Share this post


Link to post
Share on other sites

I am sorry for my stupidity, it is working now. The drivers and installation were 100% ok.

I was dumb not to think about something. In the past i set my wifi router not to accept new connections (new mac adresses) and forgot about that. thats all. shame on me.

I changed that and now writing this from osx. thank you for taking time to respond anyway.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By sudo_dudo
      My laptop doesn't have working ethernet. I use a usb wifi adapter to access internet. I can't login to AppStore as my usb adapter shows IOBuiltin = false. I've tried EthernetBuiltIn = Yes and my usb wifi shows up as en0. I am attaching my ioreg.
      Please help
      ioreg.zip
    • By FrenzyKillz
      Linksys AE6000 on macOS Sierra
       
        So after a bit of work I got Sierra installed on to my MacBook Air 2,1! The only issue is wifi. To remedy this issue till I can get a new wifi card, I decided to see if I could use my Linksys AE6000 on Sierra.
       
      Requirements:
      Linksys AE6000(or similar RT2870 card) Yosemite RT2870 kext D-Link Pref Pane(DWA-140, thanks! @rodrigocunha) Kext Utility  
      To get the Yosemite kext for the RT2870, I had to go through Mediatek's installer with Pacifist. I did try the Mavericks kext from the other RT2870 thread but it didn't work.
       
      The files will be attached below! (RT2870 Kext,DWA-140 Pref Pane file,Kext Utility
       
      Now to the process:
      I'm not sure if order matters but I had the DWA-140 Pane installed already Next drag and drop the RT2870 USB WiFi in to Kext Utility Reboot(with or without your USB Adapter attached) Your adapter should be blinking or working with the DWA-140 Utility
       
      Have fun, enjoy! 
      RT2870USBWirelessDriver.kext.zip
      DWA-140WirelessUtility.prefPane.zip
      Kext Utility.app.zip
    • By lost_loven
      Anyone use this adapter before? I have it and works great on my windows side and I can get the connection of 867 mbps but when I boot into

      El Captain (10.11.6) I can only get a connection rate of 300 mbps . .. I installed various different versions of the software driver and used its uninstaller

      as well to try and keep it clean but just wont connect no higher! Argh.. I contacted their support and no help at all.. first responce took 11 days and 3 emails..

      Still have heard nothing back since I responded to them and its been 20 days now.. Anyhow Could there be a conflict or something with my old usb wifi dongle? 

      If so how would I go about deleting its Kexts drivers? Here is some pics.. Other wise it works great.. I just want the full speed of it 

       

      Help please.



    • By MacModifier
      D-Link DWA-131 Wireless N

      http://www.ebay.com/...984.m1439.l2649

      Works great with OS X Yosemite.

      Install this realtec driver and works like a charm, did I mention it was cheap price.

      Here is the chipset this card uses RTL8192SU
      See for yourself http://wikidevi.com/..._DWA-131_rev_A1


      Download and install the mac driver to make this usb wifi stick work here.

      http://www.realtek.c...=true#RTL8192SU

      Match up with the number above when looking for the right one.

      Bing you have wifi, and for the last time, the price is right
    • By entropid
      Hello
       
      I've recently bought a WLAN USB adapter for my Hackintosh (VAIO FZ11Z): EDUP EP-N8508 with chipset Realtek RTL8188CUS.
      (Unfortunately there are no drivers available for the built-in wireless card, Intel® PRO/Wireless 3945ABG)
       
      It works perfectly with WEP and WPA/WPA2 hotspots, but I can't make it work with 802.1X.
      That protocol is supported by the chipset (in fact, it's working in Windows) but on OS X there's no option for that in the Wireless Network Utility. 
       
      I tried installing wpa_supplicant on OS X with no luck, since it's not really supported (despite their claims) and it doesn't compile. Well, with some edits it does compile but it doesn't work. 
       
      Does anyone know any way to solve/work this around?
       
      Thank you.
×