Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
g14nluc4x86

[aiuto] Scheda pci wireless problema

5 posts in this topic

Recommended Posts

Ciao a tutti, ho un problema con una scheda di rete wireless. Il modello è la TP-LINK TL-WN951N che viene riconosciuta dal mountain lion nativamente e dopo circa 2 minuti di navigazione il sistema va in kernel panic. Ho letto su molti forum che questa scheda da problemi con processori come il mio intel I5 quad core. Volevo sapere, visto che ho anche una scheda TP-LINK TL-WN851N ver.:2.0 se questa scheda può funzionare e se esiste qualche kext per farla funzionare. Ho trovato una guida nel web che dice di inserire righe di codice nel fils dsdt, ho provato ma quando lo compilo ricevo errore. Qualcuno può cortesemente aiutarmi? Grazie in anticipo a tutti

Share this post


Link to post
Share on other sites

Ciao g14nluc4x86

Per darti un aiuto dovresti postare il dsdt che hai modificato.

Dai un occhiata nella sezione F.A.Q.

 

Fabio

 

 

 

Ho semplicemente aggiunto questa parte di codice che ha postato un utente su un forum spagnolo:

 

 

 

Device (RP01) /*este es el puerto PCI donde esta conectada la WiFi segun ioreg es PCI-1*/

{

Name (_ADR, 0x001E0000) /*su ruta y el resto de codigo original*/

Method (_PRW, 0, NotSerialized)

{

Return (GPRW (0x0B, 0x04))

}

 

Method (_PRT, 0, NotSerialized)

{

If (PICM)

{

Return (AR01)

}

 

Return (PR01)

}

 

Device (ARPT) /*agregado dispositivo AirPort*/

{

Name (_ADR, 0x00010000) /*direccion fisica de la tarjeta inalambrica PCI segun ioreg*/

Name (_SUN, One) /*direccion 0x01 del puerto para que figure en el perfil del sistema*/

Name (_PRW, Package (0x02)

{

0x09,

0x04

})

Method (_DSM, 4, NotSerialized) /*comienzo de la inyeccion*/

{

Store (Package (0x04)

{

"built-in",

Buffer (One)

{

0x00

},

 

"device-id",

Buffer (0x04)

{

0x2A, 0x00, 0x00, 0x00 /*id nativo Atheros en lugar del real 0x29 incompatible*/

}

}, Local0)

DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))

Return (Local0)

} /*fin de la inyeccion*/

} /*fin de AirPort*/

} /*fin del puerto PCI-1*/

 

Ho anche installato un kext trovato in rete, la scheda viene riconosciuta, funziona, ma mentre navigo il mac va in kernel panic

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×