Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
vol264

Kernel Panic on ASUS P5Q

4 posts in this topic

Recommended Posts

Hi,

 

I have a perfect working Snow Lepoard on my hack but would like to upgrade to Lion. I've tried a lot of options, but everytime when I boot i get kernel panic (see attached picture).

 

So what is the current situation:

 

1. Have a bootable USB stick with Lion and Chameleon 2.1 (checked on real MAC and is booting OK)

2. smbios.plist (Mac 3,1 optimized)

3. com.apple.Boot.plist

<key>Boot Banner</key>

<string>No</string>

<key>Kernel</key>

<string>mach_kernel</string>

<key>Kernel Flags</key>

<string></string>

<key>Timeout</key>

<string>3</string>

<key>RestartFix</key>

<string>Yes</string>

4. Have an optimized DSDT (only fakesmc.kext is needed on SL)

5. Exrta/Extensions (FakeSMC, tried also (IOAHCIBlockStorageInjector, AHCIPortInjector))

6. Tried with kernel flags (acpi=off, PCIRootID=0 and 1, no kernel cache, no graphics enabler)

7. Have unplugged CD/DVD and 1TB disk

8. Checked BIOS settings

 

I really have no more ideas what to try.

 

Any ideas what could be worng?

 

Thanks

post-515577-0-28204200-1362726166_thumb.jpg

Share this post


Link to post
Share on other sites

Restored Lion on the USB stick again and now it goes forward but now I'm stuck on the white screen after apple logo.

 

Tried PCIRootUID, npci, GraphicsEnabler.

 

When I do -f or -s I get then th same kernel panic as in first post.

 

Are there normally problems with USB stick when restoring images onto them? I suspect that this could be the same issue.

Share this post


Link to post
Share on other sites

-f -v -x PCIRootUID=1 UseKernelCache=No GraphicsEnabler=No npci=0x2000 cpus=1

 

Use only FakeSMC.kext and NULLCPUPowerManegemente.kext in S/L/E of your USBInstaller, in the root USBInstaller folder Extra with smbios.plist/org.chameleon.boot.plist/DSDT.aml, make a new USBInstaller with MAP/MBR Format/HFS+ , RESTORE with Disk Utility .dmg LION, InstallChameleon, make a Extra Folder, and try again, in your photo I see what the problem is Installer corrupt or you have made this wrong, serch for a guide how to mke a USBInstaller, take a look here.

 

The all-in-one guide to Vanilla OS X Mountain Lion + Chameleon + DSDT for beginners http://www.insanelymac.com/forum/index.php?showtopic=280756

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×