Jump to content
InsanelyMac Forum
argisak

Help with Chameleon!

Recommended Posts

I apologize if I write the wrong topic but I did not know where else to write why I am calling solution. I am having two problems that I am looking to find a solution too long. Related to the Chameleon. If my system boot from the hard drive then my system does not have ethernet and icons of hard drives have an orange color. If you boot from USB STICK then my system works normality. What I do right?

 

In system info says that SATA Controller is: "Unknown AHCI Standard Controller".

Share this post


Link to post
Share on other sites
Advertisement

Orangefix AppleAHCIPort.kext.zip and for internet post your card , this can be caches problem or you not have installed correct kext for your card

Thank you for your answer iFire. The AppleAHCIPort.kext is already is S/L/E folder from Apple when i install Lion!

 

My Ethernet card is:ADAPTER TP-LINK TG-3269,with RealTek RTL8169SC, 10/100/1000Mbps Auto-Negotiation RJ45 port, Auto MDI/MDX. I find the kext: AppleRTL8169Ethernet.kext from olarila.com/kext/ Is correct for Lion 10.8.2?

 

But, Why when you boot from the Usb Stick I have no problem?

Share this post


Link to post
Share on other sites

The problem with the color orange as solved and ethernet. Thank you again! All that remains in the System info saying: "Unknown AHCI Standard Controller" for Sata Controller.

Share this post


Link to post
Share on other sites

open the infoplist and Edit it with the name of your controller, look this Example,

 

 

<key>GenericAHCI</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.AppleAHCIPort</string>

<key>Chipset Name</key>

<string>AHCI Standard Controller</string>

<key>IOClass</key>

<string>AppleAHCI</string>

<key>IOPCIClassMatch</key>

<string>0x01060100&0xffffff00</string>

<key>IOPCITunnelCompatible</key>

<true/>

<key>IOProbeScore</key>

<integer>800</integer>

<key>IOProviderClass</key>

<string>IOPCIDevice</string>

<key>Vendor Name</key>

<string>Unknown</string> Put the name of your controller here

</dict>

<key>ICH10AHCI</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.AppleAHCIPort</string>

<key>Chipset Name</key>

<string>ICH10 AHCI</string>

<key>IOClass</key>

<string>AppleAHCI</string>

<key>IOPCIPrimaryMatch</key>

<string>0x3a228086</string>

<key>IOProbeScore</key>

<integer>2000</integer>

<key>IOProviderClass</key>

<string>IOPCIDevice</string>

<key>Vendor Name</key>

<string>Intel</string>

</dict>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×