Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
srsx

TP Link WN781ND can't connect to any protected networks

4 posts in this topic

Recommended Posts

Hi all!

 

When I finished installing Mountain Lion, I imported my things via the built-in "transfer from another mac". Upon fixing wireless, console spews this out when trying to autoconnect to my network. Minor censoring of the obvious here:

 

2/9/13 11:52:44.369 AM airportd[261]: _processSystemPSKAssoc: No password for network <CWNetwork: 0x7f8033e03fd0> [ssid=ssidhere, bssid=so:me:da:ta:he:re security=WPA2 Personal, rssi=-62, channel=<CWChannel: 0x7f8034a05e90> [channelNumber=6(2GHz), channelWidth={20MHz}, active], ibss=0] in the system keychain

 

From what I am reading, there is an entry in the system keychain for my network, with an empty password. On the very same SSID, channel, etc with no security (except MAC filtering) it can connect fine. I have looked inside the "Keychain Access" app and removed it's entry, aswell as removing some network related preference list fiels, and booting with a flushed cache.

 

Help me out here?

 

Thanks, very much.

 

this is wrong forum, i know, reposting into networking now. sorry

 

UPDATE: SOLVED

I noticed in my console AHR: unknown locale {censored} (something like that), googled, found my chipset. AR928X will work with this:

 

http://www.archive-host.com/files/1299124/98d9954ac73c5bbe45b69529396e23a074788300/WIFI_AR928X.zip

 

Allowed me to connect to WPA networks with TL-WN781ND on 10.8.2, cheers!

Share this post


Link to post
Share on other sites

Bumping with findings:

 

I can connect to a WEP network, but not any kind of WPA. For now I am using a 2870 usb stick I had laying around, and it has WPA fine. This card worked PERFECT in 10.7.x, but now doesn't have WPA in 10.8.

 

I had to switch kexts when I updated, and I am lead to think the kext has caused it, or something with wpa_supplicant?

Share this post


Link to post
Share on other sites

There is a possible way to test if it is a kext issue.

 

Create a new account and log into it. If you can access WPA networks, then its most likely not a kext issue (prob some far away config file)

Share this post


Link to post
Share on other sites

I tried that, I was unable to connect. Anyone help me find a kext for ML 10.8.2 and TPLink WN781ND?

 

md5 of my current, nonworking kext's version.plist: 92e7fe9fb74acce51c5026beff1d6df8

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×