Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
3.14r2

[Solved]Time Capsule WEB access from XP/W7

2 posts in this topic

Recommended Posts

Hi all!

 

I've faced a problem which I don't know how to solve. Out of ideas. Maybe someone could share some knowledge on the subject?

 

The deal:

I friend of mine has a time capsule connected to Internet 24/7 via another ISP provided router. In other words the topology is fallowing:

  • Fibre optics from ISP > ISP provided modem > ISP provided router

She wants the TC to be accessible via WEB (not only in the apartment she lives in and where all the devices are located). She has two Macs. Now I've managed to connect both Macs via web (using AFP). In order to do this the following steps were taken:

Configured the ISP proved router to assign a static IP address to TC (using TC's MAC address)

Configured the ISP proved router to do a port forwarding TC

Configured the TC to enable both file sharing and sharing to WEB (so now it is enabled as second router otherwise share to WEB option would not be available)

 

She can connect both here Macs (LI) to the TC other the web with no issues. So do I from my Hackintosh (SL). But she also need the TC to be accessible via WEB from Windows machines (XP/W7/W8) for co-workers to be able to add their files (dropbox is not an option). Here comes the problem. I couldn't make it happen. XP just doesn't want to connect. :wallbash: I've tried both \\XX.XX.XX.XX:port number or via browser. Nothing...

 

Unfortunately TC can't be used as the only router, as TV signal is also provided via the same channel as the Internet ant the modem (or whatever that thing is called) on the TV side JUST DOESN'T work when connected to TC, butt works perfectly then connected to ISP provided router. :wallbash:

 

Thanks for any ideas!

Share this post


Link to post
Share on other sites

The solution was more or less simple. Using only free tools.

  1. I've installed VirtualBox virtual machine.
  2. Installed Ubuntu as a guest OS
  3. Installed AFPFS-NG (AFP Linux port)
  4. Created few scripts to connect/disconnect to TC and used them to create desktop launchers (to double click the icon instead of finding and executing scripts)
  5. Added AFP daemon to be launched on logon to OS
  6. Shared Windows Documents folder for it to be available in Ubuntu (although drag and drop function is present in VB, it didn't worked well in my case)
  7. Created launcher to open the shared Windows folder (using a simple script again)

 

That's all!

 

Few useful links:

http://www.omgubuntu.co.uk/2010/11/connecting-to-your-apple-time-capsule-in-ubuntu

http://www.linuxquestions.org/questions/programming-9/executing-shell-script-in-terminal-directly-with-a-double-click-370091/

http://www.ax697.org/writing-a-basic-ubuntu-script-200786.html

https://www.virtualbox.org/

http://old-releases.ubuntu.com/releases/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Yup that's fine! Oddly, when rebooting several times it is suddenly gone! Only thing I need to fix is getting 'Headphone' output to work, after sleep. Internal Speakers are working after sleep. I assume to fix this in CodecCommander.kext/ EAPDFix.kext? Anyway thanks for your help!   Yup I have a combo output, so there was something wrong I guess.
    • Nice @yapan4 then we can join forces to make this as good as possible.
    • I had a weird situation, after running great for a while: yesterday I did a reboot and got a KP. Turns out the AstekFusion2Adapter kexts were causing the KP, strange thing is I didn't recall applying any update or a like.  I had to boot with the USB installer, mount the EFI partition to delete the old AstekFusion2Adapter kexts and replaced with the patched version contributed by despeinao. I'm glad the system is working again, not having to reinstall OSX.
    • i think the "red light" you are referring to is that you have a optical SPDIF output (3.5 mm) combo jack. it most likely will be "red" when audio is active. 
    • Domanda , ma il tuo configplist lo ha settato cosi Gengik????
      Noto molte cose atipiche , tipo aperto con Clover configurator nella sezione ACPI il nome DSDT.aml NON è selezionato , quindi in teoria NON dovrebbe caricare il DSDT che hai in Clover ACPI Patch , se usi SSDT x la CPU NON dovrebbero servirti quelle personalizzazioni sempre in configplist sezione CPU ...
      Secondo me dovresti partire da un configplist pulito , xche sempre secondo me c'è rimasto delle schifezze di qualche tool x installare facile    EDIT
      Scaricando il configplist di jolly NOTO ha impostato +o- come intendevo fare io , sistemando quello  sopra elencato e bammmmm NON avvia , mi forniresti x favore Hack info che trovi nella mia firma ???
      Grazie   Ho creato un configplist , se vuoi provare , dovrebbe essere pulito da ogni impurità , se funziona dovrai adattarli tutte le tue personalizzazioni x il boot ..... config.plist.zip


×