Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
whYTee

Early '11 MBP Optibay can't mount/unmount any HDD (sata2 or sata3)

4 posts in this topic

Recommended Posts

So, I've been trying to move my WD Scorpio Blue 1TB HDD into an ebay generic optibay (in an early '11 i5 mbp8,1 running Snow Leopard 10.6.8). The HDD fit perfect, but when trying to.. well, do anything with it, Disk Utility fails to partition/erase/repair it, and I tried using a few different terminal commands to force erase and partition it (ended with errors saying things like "couldn't unmount disk," "Input Output error," and "cannot allocate memory"). Tried a few spare hdd's I had in external cases, but there was no difference. Can't see the hdd's in finder but disk utility at least recognized there was a drive, just couldn't do anything with it.

 

Also tried a samsung 830 ssd I just got - same errors (expected with the sata3 drive in the optibay though). Having the hdd/ssd in the optibay seemed to make everything slower too, it would take at least a minute before the apple logo appeared on boot (may have just been startup disk preferences), and disk utility would hang when first starting it (sometimes wouldn't hang so long I had to force it to quit). Tried resetting PRAM too. Searched to no avail on this specific problem, so here we are... Any help is appreciated!

Share this post


Link to post
Share on other sites

For the record, I had the seller (bought it off eBay) send me a replacement, and the replacement optibay works flawlessly. Must have just been faulty.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×