Jump to content
InsanelyMac Forum
InfiniteFool

Gigabyte GA-Z77-D3H - sleep not working

Recommended Posts

So I recently installed ML on the following system:

 

Gigabyte GA-Z77-D3H motherboard

Core i7-3770K processor

ASUS GTX 560 Ti

G.Skill 16GB(2x8GB) SDRAM

SanDisk 240GB SSD

Samsung 1TB 7200RPM HDD

 

I did a dual-boot on the SSD with ML and Windows 7. I currently have everything working - including video, sound, network, shutdown/restart, USB 3 - EXCEPT for sleep. When I try to sleep, the screen turns black, but all the fans are still running and the HDD light is still blinking. If I click the mouse or press a key it comes up again with the login window. So it's acting as if it is sleeping, without actually sleeping. I suspect there may be a setting I need to change in my bios, but I'm not sure. I don't have DSDT installed, and I'd rather not, because I'd like to keep my setup as simple as possible. Supposedly DSDT is not necessary with the new Gigabyte Z77 motherboards,

 

Here is how I installed the OS:

 

I booted from a flash drive using PCIRootUID=0 (it wouldn't boot otherwise). It installed without issue. Then I used ###### to install Chameleon to the SSD along with network drivers. Then I installed the VoodooHDA kext to get the sound working. The first time I installed the OS, I installed the 10.8.2 update, and it worked with no issues. I've since reinstalled the OS using the exact same method, but I haven't installed the update yet.

 

I have tried deleting NullCPUPowerManagement.kext and AppleIntelCPUPowerManagement.kext to no avail. I've also tried installing a sleep enabler. No luck. Any suggestions?

Share this post


Link to post
Share on other sites
Advertisement

You need to keep AppleIntelCPUPowerManagement (AICPUPM for short :P), but in order to use it you must either 1) patch it as coelomate1 said, or 2) patch your DSDT. You can try NullCPUPM + SleepEnabler, but that's designed for legacy Intel and AMD machines, so I can't guarantee it, and besides having full power management is better anyway. ;)

Share this post


Link to post
Share on other sites

/System/Library/Extensions/AppleIntelCPUPowerManagement.kext

 

 

Did you patch that kext?

 

 

No, I did not. Do I need to patch it myself, or can I just install an already patched version?

Share this post


Link to post
Share on other sites

Bump? I have both patched AICPM and installed DSDT for my machine. It still will not sleep. It's not a huge issue, since the computer boots very quickly (20-30 seconds), but it's somewhat of an annoyance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×