Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

I have DSDT.aml for MAC OS X 10.6.8... will it works on Lion 10.7.X?

10 posts in this topic

Recommended Posts

Hi guys,

I great man helped me to patch the DSDT.aml of my Asus netbook while I was trying to install Snow Leopard 10.6.8... can I use that DSDT.aml in Lion or have I to extract and path it under Lion?




Share this post

Link to post
Share on other sites

if it worked in 10.6.8 it should work in 10.7

10.7 needs AppleRTC.kext bin patched ( rtc reset 10.7 sleep fix)


Thank you very much man!


I've just discover that the DSDT that I've used in Snow Leopard is exactly the same of the one I've just extracted in Lion.... may be I'm wrong with the files or the DSDT I've used in Snow Leopard doesn't contains any patch...


Please, can you help me starting from scratch with the DSDT in Lion? I've tryed all my best but it seems I don't have the knowladge to do that work... :(

Here there is my S.O.S. post:


Share this post

Link to post
Share on other sites

when using a DSDT.aml in /Extra.. when u extract dsdt it will be the same in the /Extra folder as its loaded replacing the real dsdt from mobo..


have to use linux in usb or boot OS X without dsdt to extract real dsdt not patched.


when u boot linux in USB

get online then in terminal:


sudo apt-get install acpidump iasl

### or depending on linux used

sudo yum install pmtools iasl



mkdir ~/acpiinfo ; cd ~/acpiinfo

sudo acpidump > acpidump.txt

sudo acpixtract acpidump.txt

ls *.dat | while read i; do iasl -d "${i}"; done

name=`sudo dmidecode -s system-product-name`


mkdir "${name}" && cp *.dsl "${name}"/


now check your home folder for the dsdt inside a folder.. .ohh cant put it in the USB thats booted linux? dont have a second USB?

upload it to www.mediafire.com

Share this post

Link to post
Share on other sites

I've used this command to retrieve the DSDT:

perl -e 'open(CMD, "ioreg -lw0 \| grep DSDT|") or die; while(<CMD>) { chomp; if($_ =~ /\"DSDT\.?\d?\"=<([^>]*)>/) { $buff = $1; open(PIP, "|xxd -r -p > ~/Desktop/dsdt.aml") or die; print PIP "$1"; } }'


... that means that in the way I've used the generated DSDT file is just patched for my system? Can I use it or have I to do the "Linux way"?


Many thanks for your support, I really appreciate. :)

Share this post

Link to post
Share on other sites

its not patched.. if u used a dsdt with someone having patched it and u boot with it.. when u do that command, u still going to get the patched dsdt.. not the unpatched original.


the extraction of dsdt does NOT patch it.


i just noticed u said NETBOOK.. means atom processor. means u need kernel that is patched for atom.

Share this post

Link to post
Share on other sites

Ok, thanks!

Just to understand: I don't need the unpatched/original DSDT... I'd like to have the correct DSDT patched for my system so after installed the iAtkos I've execute the command I wrote and I've got the DSDT fiel on my desktop. My question is: this DSDT is the DSDT correctly patched for my system (can I just put it in /Extra?) or have I to patch it manually and then use it?

Which patch can I add and/or wich patch have I to add in order to get the sleep working?


May be my problem after upgrading to 10.7.5 combo is because I didn't change the mach_kernel before restart after the update?

Where can I find the correct atom kernel for Lion 10.7.5?




Sorry for the milion wuestions? :)

Share this post

Link to post
Share on other sites

not sure i never used iatkos.. i used kalyway in 2008 before dsdt was the way.


i havent messed with netbooks in 2 yrs. wrong person to ask.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Did you tried use ACPIBatteryManager.kext for the Battery? And for brightness you can use IntelBacklight  Both created by @RehabMan 
    • I have put it into clover drivers 64uefi folder on Yosemite thru High Sierra which allows me to edit my High Sierra disk if needed in Yosemite system.   There is no functionality of apfs in other versions but it does allow other clover bootloaders and systems to recognize the HS apfs drive or open it for inspection.   If you don’t have it you can’t see your HS drive or access it in another macOS version.
    • Hi! Is it possible to get codec AD1981 running with AppleHDA on HP Compaq 8710w? It works nicely with VoodooHDA. Speakers and HP are switching automatically.  Internal and HP mic also work - no switching in SysPref but it works when mic is plugged in and internal mic works when hp mic is unplugged.   It has same weird pathmap - connected directly:  Playback: nid=5 [pin: Speaker (Analog)] | + <- nid=3 [audio output] [src: pcm] bindSeq=00008001 nid=6 [pin: Headphones (Grey Left)] | + <- nid=3 [audio output] [src: pcm] bindSeq=00008001   But inputs are really weird. There are 5 nodes from input to HP mic/Internal mic nid=4 [audio input] | + <- nid=21 [audio selector] [src: mix] bindSeq=00000003 | + <- nid=12 [audio mixer] [src: mix] bindSeq=00000003 | + <- nid=30 [audio selector] [src: mic] bindSeq=00000001 | + <- nid=8 [pin: Microphone (Grey Left)] [src: mic] bindSeq=00000001 + <- nid=31 [audio selector] [src: monitor] bindSeq=00000002 | + <- nid=24 [pin: Microphone (Analog)] [src: monitor] bindSeq=00000002 Can pathmap like that even work with AppleHDA? What codec should I patch? I tried patches from AD1984 but no luck.    These are manually patched verbs: 00571c10 00571d01 00571e17 00571f90 00570C02 00671c20 00671d10 00671e21 00671f03 00771cf0 00771d00 00771e00 00771f40 00871c30 00871d10 00871e81 00871f03 00971cf0 00971d00 00971e00 00971f40 00a71cf0 00a71d00 00a71e00 00a71f40 01671cf0 01671d00 01671e00 01671f40 01771cf0 01771d00 01771e00 01771f40 01871c40 01871d01 01871ea0 01871f90 01971cf0 01971d00 01971e00 01971f40   Codecgraph and linux codecdump attached. Thx for any help or suggestions.              codec.txt 2.svg codec.txt
    •   Yes, 'cause APFS log is coming before clover boot screen.