Jump to content
InsanelyMac Forum
famousginni

Lenovo Y560 DSDT

Recommended Posts

So, I've gotten 10.7.1 running on my laptop. I could say 95% of it is working. My VGA port is not working, the battery life is meh even with Native SpeedStep working, and the audio through HDMI isn't working. I have a ALC272 on this laptop running with Voodoo HDA, but I would prefer if I can get it working without it.

 

Many of the fixes that I've see that might work use DSDT and I no nothing. I've tried following tutorials but that isn't working... anyone want to help me with this daunting task?

Share this post


Link to post
Share on other sites
Advertisement

Here are the files that you requested. Keep in mind I have QE/CI with FullRes enabled using native Lion Drivers with GraphicsEnabler=Yes, and AtiConfig=Orangutan. The HDMI works without sound, but the VGA does not.

 

DSDT: https://www.dropbox.com/s/eyjj32t70acq9tl/dsdt.dsl

 

IOREG: https://www.dropbox.com/s/qbt1vemqmp81rnb/famousginni.ioreg

 

I tried attaching them as attachment but for some reason it wouldn't let me so I used dropbox instead.

Share this post


Link to post
Share on other sites

Attached is a new DSDT. Install in your Extra folder and then restart. Also attached is a working AppleHDA for ALC272 which should enable onboard audio.

 

I also injected your GPU into the DSDT so you should no longer need GraphicsEnabler=Yes

 

Post a new IOreg after restart.

Files.zip

Share this post


Link to post
Share on other sites

Hey I tried your new DSDT and the driver for ALC272 and the VGA port worked with the new DSDT. I'm having trouble using it though as if I turn on mirroring the screen on the external gets distorted and without mirroring it works fine. I also need to add a higher resolution as all the resolutions listed are not the full resolution of my monitor. The modified ALC272 kext on the other hand did not work. I used kextstat to see if the kext was loaded and it wasn't loaded so maybe I need to add my device IDs or something. I will send you the new IOreg. Also would it be possible for you to send me the modifications you made in the DSDT as I have another DSDT with the VGA not working but it has shutdown and restart working perfectly so hopefully I can combine them together or something.

 

Edit: Added DSDT Link https://www.dropbox.com/s/cfoicqwtsw962y3/famousginni_new.ioreg

Share this post


Link to post
Share on other sites

Do you have any problem when the monitor goes to sleep and then back on ? I have Y560 the one with i5 430M and switchable graphics and everytime monitor goes to sleep and then back on, the video crashes and the colors are all messed up!


 


The sleep semi-works (i can get it to sleep but never wakes up, i think i have a KP from video card but i don't know where to look for it)


 


Also, although in system report i get "Pixel Depth: 32-Bit Color (ARGB8888)" i have problems with shadows and gradients, they don't display well... like they are in 16-Bit color mode.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×