Jump to content
InsanelyMac Forum
Sign in to follow this  
bgrau

DSDT for Dell Dimension 9200 (aka XPS 410)

Recommended Posts

I have attached the DSDT.aml for my Dell XPS 410 rig which I tried to optimise for sound output, particularly HDMI...

 

please have a look at the thread I made (about the particular graphics cards I now use):

 

http://www.insanelym...alit-case-study

 

What I have noticed is that when we use different video output ports, the NVCAP value changes in the hardware ioregister... so we need more than one entry for video ports...

I used only one which only allowed me to input one NVCAP at a time (of course NVCAP can also be included in the chameleon plist)...

 

The NVCAP calculated from the graphics card rom dump corresponds I believe to the port closest to the mobo...

 

In my thread I detail all these things...

 

The problems I still have are:

 

- No system control of HDMI sound... (but hdmi sound available to applications, and it is possible to control the hdmi sound from within the apps, like vlc, quicktime, etc.)

 

- Having to reboot at least twice to get to the desktop when using pure HDMI connection...

 

- No on-board HD sound for the Sigmatel 9227 (but that is ok because my external usb creative sound is recognised natively now by Mountain Lion)

 

I used VoodooHDA 2.73 modded info.plist for hdmi...

 

Any help appreciated...

 

Last question: does Slice Clover upgrade Chameleon safely and nicely? I want to try to see if it improves hardware detection and operation...

Share this post


Link to post
Share on other sites
Advertisement

Remove VoodooHDA and reinstall AppleHDA then restart. Next extract a IOreg and DSDT from your system and post it here. Please list the GPU and BIOS version.

 

Maybe I can learn here :)

 

Here goes:

GeForce GTS 450 VGA BIOS

Version 70.26.27.00.00

 

and attachments...

 

incidentally, using the native AppleHDA.kext gave me trouble to reach the GUI in ML (I remember doing a time delay patch..., I might need to do it again)...

Dell9200.ioreg.zip

DSDT.zip

10de_1245.rom.zip

Share this post


Link to post
Share on other sites

Install this DSDT in your extra folder then restart and post a new IOreg.

 

Thanks...

No sound detection yet (in MLion)... Dell9200_2.ioreg.zip

 

An improvement with VoodooHDA thanks to something I found out, so far only obeserved in Snow Leo, and I did not check yet if sound does come out from the onboard sound card (sound does come out from HDMI but I only would get HDMI out without the HDEF onboard output)...

 

more later, this little observation might deserve a thread of its own, if it indeed allows sound out, not just cosmetic appearance...

 

another thing, I booted straight into Mountain Lion, without having to do it several times before the GUI kicks in... don't know if it's being lucky, or your DSDT solved this, which in itself will be great...

so I will use this same DSDT on Lion, and see how it fares (I have VoodooHDA on Lion)...

 

Well booting up into the GUI, I think now your DSDT patch fixes it...

I am now in Lion, and also at my first attempt I booted into the GUI...

so far so good...

sound is not detected in System Profiler despite VoodooHDA, but now both HDMI and some output ports of the on-board get detected...

before only HDMI will be on System Profiler...

nothing to do with your mod though, as this is due to my mod of VoodooHDA 2.73 / 2.74 which I will explain later...

so something in your DSDT interferes with this (cosmetic HDMI in System Profiler)

 

If I plug in my external Creative USB SoundBlaster it will get detected as it is now native in ML... (probably a deal between Apple and Creative, lol!)

 

PS I included my VoodooHDA findings here:

http://www.insanelymac.com/forum/topic/284480-voodoohda-sigmatel-9277-nvidia-450-gts-hdmi-sound/

Share this post


Link to post
Share on other sites

I guess this is a better improved DSDT for Dell Dimension 9200 with Geforce GTX 470

 

dvi-i to hdmi

 

hdmi nvidia and onboard sigmatel 9277 hidef sounds nicely handled by VoodooHDA though (using no-KP's voodooloader)

 

and put up together in Snow Leopard using ioreg data (0 errors, 0 warnings, 0 comments in iasml compilation):

 

DSDT.aml.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Posts

    • The forum is infest of ads and Video pub
      Please it is possible to remove ads for members thanks
    • Unfortunately, removing the THB cable isn't working with the ASRock MB, no TB devices show up at all...   When I had the gigabyte Gaming 7 Pro and was waiting for the connector adapter (GB uses a different header pitch: 2mm vs 2.54mm) no TB devices were seen in macos either...
    • Ok so I was having issues with on-board and HDMI audio using VoodooHDA. No AppleALC due to AMD setup. VoodooHDA was crackling on on-board and couldn't sort and there was no HDMI output. So I bought a Sabarent AU-MMSA USB Audio device. Issue is it's acting just like the on-board audio was. With or without VoodooHDA being injected.   Any suggestions?   https://i.imgur.com/AU5uzEQ.png   https://i.imgur.com/I1tmrhk.png    
    • salve a tutti ho questo laptop con ati hd 6370m, tuttavia la risoluzione non è corretta, sulle informazioni dice che ha solo 3mb di ram, qualche consiglio?
    • This is my first hackintosh Build.
      I installed windows 10 and made sure everything was working then
      i Change my bios settings. (See Below)
      I Created a ##### usb with latest version of high Sierra 10.13.4 then installed it after erasing the whole drive
      Booted into MacOS then ran [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] with these settings below then that when i Get the black screen after clover boot screen then i have to turn off the monitor and turn it back on to get a picture on one of my monitors.. I have 2   Ethernet is working


      MOTHERBOARD
      GIGABYTE Z370 AORUS Gaming 5

      CPU
      Intel Core i7-8700K Desktop Processor 6 Cores up to 4.7GHz Turbo Unlocked LGA1151 300 Series 95W BX80684i78700K
      Graphics Card
      Gigabyte AORUS Radeon RX 580 8G 8GB GDDR5 256bit Graphics Card GV-RX580AORUS-8GD
      Cooling
      NZXT Kraken X62 All-in-One 280mm CPU Liquid Cooling System
      Ssd Hardrive
      Crucial MX300 1TB 3D NAND SATA M.2 (2280) Internal SSD
      Memory
      G.SKILL TridentZ RGB Series 16GB (2 x 8GB) 288-Pin DDR4 3000MHz (PC4 24000) 
      CASE
      Nzxt S340VR Elite Computer Case
      Bluetooth / WIFi (removed onboaard wifi and put this card)
      Broadcom BCM94352Z M.2 NGFF 802.11AC 867Mbps BT 4.0 DW1560 for Mac Hackintosh
      Power supply
      EVGA SuperNOVA 650 G3 650W 80 Plus Gold Modular Power Supply

      ##### Settings Quick Start - UEFI Boot Mode Drivers Audio - Misc FakeSMC Plugins FakeSMC HWMonitor Application Network - Intel - Choose latest IntelMausiEthernet USB - Increase Max Port Limit 200 Series Bootloaders - Clover v2.4k r4063 UEFI Boot Mode + Emulated NVRAM Customize Graphics Configuration - AMD Graphics Fixup (required for AMD card!) System Definitions > iMac - iMac18,3  




      UEFI/BIOS settings After POST beep, press/hold DEL key to enter UEFI/BIOS Save & Exit menu - choose Load Optimized Defaults. MIT > Advanced Frequency Settings > Extreme Memory Profile (X.M.P) - choose Profile 1 BIOS Full Screen LOGO Show - I disable this, but not really required Boot Option Priorities - set this to the UEFI option for your UB flash drive. Disable all other choices. Once we run #####, we’ll come back in here and set to your new boot drive (in my case, the UEFI partition of Samsung 960PRO). CSM Support - Disable. Note that the Storage Boot Option Control option which is set to UEFI (desired setting) disappears along with the other 3 options under CSM Support when you set to Disable. Don’t worry, as Storage Boot Option Control apparently stays set to UEFI “under the hood.” Peripherals Initial Display Output - mobo should auto-detect your GPU card, so this should already show PCIe 1 Slot. You shouldn’t have to do installation using internal GPU, then switch to your GPU card. Peripherals > LEDs in sleep, Hibernation, and Soft Off States: OFF [this is optional if you don't want LEDs on 24/7, even in power-off state). USB Configuration > XHCI Hand-off - set to Enable Note: Once Thunderbolt3 AIC is connected, a new dynamic menu option for configuring the Alpine Ridge card appears below the USB DAC option (which lets you set options for USB charging on the appropriate ports). Chipset VT-D - Disabled Internal Graphics - Disabled (this also turns off the DVMT menu options). Wake on LAN Enable - Disable Power ErP - Enabled [UPDATE 25Mar2018] - This is now required to help fix issue where mobo on-board LEDs do not power off when in sleep/shutdown mode. Soft-Off by PWR-BTTN - I set this to Delay 4 Sec. Save & Exit - Choose Save & Exit Setup - this saves your changes and reboots your system.  
×