Jump to content
InsanelyMac Forum
lithiumion

VAIO PCG-11211L Black Screen (Geforce 310m) ML 10.8.2

Recommended Posts

Hello,

 

I got this nice machine from a friend. After trying to install ML on it for a whole day with no success I decided to clone my already working 10.8.2 installation running on a GA-Z77X-UD5H onto a disk and plug it into the Vaio.

 

It boots without a kernel panic but to a black screen. If I boot verbose I can see the text freeze after the [PCI configuration begin]

 

I know the machine is up and running cause there is disk activity and it responds to keyboard strokes. I booted it into SUM and although the text was frozen on the screen it rebooted when I typed "reboot" and hit Enter.

 

So, I'm pretty sure this is a GPU detection issue.

 

It has an i5 CPU, Geforce 310m (ID=0x10DE0A75), Atheros Wifi, Realtek Audio, and a touch screen.

 

So far I have tried multiple boot variables such as PCIRootUID=0/1, npci=0x2000/3000, GraphicsEnabler=Yes/No, UseKernelCache=Yes/No both with and without -v/-f/-x/-r . But the result is always a black screen right after the [PCI configuration begin]

 

I have tried one NVEnabler.kext and it gives me some scrambling colours on the screen. This is the only way I'm able to see anything on that machine's screen.

 

I have also tried adding the device ID "0x0A7510de&0xffe0ffff" to both NVDAGF100Hal.kext and NVDANV50Hal.kext to no avail.

 

Any ideas?

 

Help is really appreciated.

 

Thanks

Share this post


Link to post
Share on other sites
Advertisement

I`ve the same problem in my Samsung R480 with 310m and for my works, write in chimera BootLoader PCIRootUID=0, after you boot go to /Extra folder and open the file org.chameleon.Boot.plist and put:

 

<key>PCIRootUID</key>

<string>0</string>

This its for every time you boot don`t have to write again PCIRootUID=0.

I hope this works for you, sorry for my english lol.

Share this post


Link to post
Share on other sites

So couple of days ago I gave it another shot with a 10.9 myHack USB stick and it worked!

 

All I had to do is to boot with PCIRootUID=1. Same flag was useless with 10.6, 10.7, and 10.8 installations. 

 

The machine booted and OS X installed just fine. Except for CI/QE which don't work still. No graphic acceleration.

 

The GPU is nVidia GeForce 310m with 512MB of VRAM

 

Any clues on how to get CI/QE work ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By killer5
      Hy Guys i've Trying to running Mavericks into a 1Tb Disk and finally (with lots of Bootflags) reach it.
      unfortunately its bricks my boot loader MBR partition Table but in Another disk i Have another installation of Mountain Lion
      where i can access Mavericks Folders so I get to Copy Keyboard Layout Bundle from it and Use on Mountain Lion
      a Very Usefull Layout For Brazilians as me I Hope that it can Help Some One

      It'll be attached  
       
      To replace First make a Backup Of Yours afterwards paste it At S/L/Keyboard Layout folder
      AppleKeyboardLayouts.bundle.zip
    • By JacoLoco
      Ciao a tutti ragazzi,
      Sulla mia macchina (l'Hackintosh che trovate in firma)è successo un errore piuttosto strano, mentre giocavo a "Red crucible 2" e cercavo di rispondere ad una chiamata skype, ho sperimentato una specie di freeze del mac.
       
      Disorientato ho riavviato il pc un paio di volte cercando di capire cosa fosse e ho scoperto che mentre il pc continua a lavorare ed ad eseguire qualsiasi comando gli indichi da tastiera, non c'è un nessun movimento-cambio\refresh delle immagini sullo schermo. Quindi l'immagine si blocca casualmente, al log in,dopo un paio di minuti dall'avvio, o prima del log.(ma mai nella schermata con la meletta grigia d caricamento)
       
      Così ho pensato di correggere i driver video con un nuovo aggiornamento dell'OSX portandolo da 10.8.2 al 10.8.3 ma senza nessun risultato. Ho provato ad avviarlo ignorando la cache, per finalmente riuscire ad avviarlo (piuttosto stabilmente anche se con qualche sfarfallio strano) in modalità sicura con -v -x
       
      Cosa posso fare ora per riportare la mia scheda video alla sua stabilità?
      Vi ringrazio in anticipo.
    • By rebel4ever
      Hi guys! Im using a Vostro 3750 i5, nvidia 525m & HD3000, managed to install ML on my vostro with a 525m kext added to S/L/E. The problem is i can boot it only with -v-x flags. Booting freezes at "NTFS volume name , version 3.1." if im not using any flags. What can i do?
       
      L.E.: managed to boot without any flags but i cant chage resolution. Both cards appear on system info and HD3000 has a "no kext loaded". Tried a few from the web, all fail. Any suggestions?
    • By Orsi3D
      I just got a Niresh12495 AMD compatible 10.8.2 distro but I keep gettings this error:
      "Unable to set 'OSX' as boot disk: The bless tool was unable to set the current boot disk
      Install failed: The installer could not start up the computer from the disk "OSX"
       
      Motherboard: Asus Crosshair Formula V
      Chipset: AMD 990FX
      Processor: AMD 1090t
      RAM: 4x4Gb Corsair 1333
      Video: EVGA nVidia GTS 450
       

       
      Any tips, tricks or guides?
       
      Tks!
    • By franyel
      Buenas, saludos a toda la comunidad http://www.insanelymac.com, soy novato en este mundo hackintosh. Tengo una:
      ACER Aspire 473 6 con las siguientes características
      Procesador: Intel core i3 M370
      Video: Intel hd.
      Audio: Realtek ALC269
      Wifi : Atheros AR5B95
      Lan: Atheros AR8152/8158
       
      Logre instalar mountain lion 10.8.2 pero actualmente no logro hacer que el audio funcione he leído en los foros que debo parchar el dsdt lo cual leyendo un poco logre hacerlo, pero el sistema no carga. espero me puedan ayudar.
      Adjunto dsdt.
      DSDT.zip
×