Jump to content
chema Gon

Habilitar salidas DVI HDMI tarjeta geforce nvidia 9800gt 1024 mb ML 10.8.1

4 posts in this topic

Recommended Posts

Hola,

 

He instalado Mountain Lion 10.8.0 mediante myhack

 

 

Despues instale los kexts de audio, video y red, y smbios.plist como macpro3,1 y todo parece funcionar bien en principio.

 

La instalacion la hice con un cable VGA a VGA en un monitor por que en experiencias pasadas en Snow Leopard con cable HDMI-HDMI o DVI-HDMI, la pantalla me quedaba en negro.

 

Ahora al probar con los cables DVI o HDMI en 10.8.1 me pasa lo mismo.

 

 

He actualizado Mountain Lion a 10.8.1 y instale el driver de Nvidia

304.00.00f20, pero me sigue pasando lo mismo,la pantalla sale el logotipo de apple, pero cuando se tiene que ver el escritorio se pone las pantallas en negro.

 

 

He probado crearme mi DSDT con dsdt editor, donde me he extraido el dsdt, lo he parcheado con el parche de la placa madre p5qlpro, he comprobado con io registry esplorer el NVCAP y veo que es idéntico.

Pero el resultado es el mismo, no tengo salida por DVI ni tampoco por HDMI.

 

Con la salida VGA, puedo cambiar de resolucion gracias a los kexts Geforce.kext y Nvdaresman.kext y en la informacion de miMac puedo ver que la tarjeta grafica la reconoce bien. Geforce 9800 GT 1024 MB

 

No se, si lo que tengo mal sera el DSDT que se tiene que aplicar algun codigo de los conectores de la tarjeta grafica, o es que esta tarjeta no es compatible con la version 10.8.1.

 

 

 

Las caracteristicas de mi equipo son:

 

Placa base: Asus P5QL Pro

 

Procesador: QuadCore Intel Q9400

 

Memoria: 8Gb DDR2 800 Mhz T

 

Tarjeta grafica Asus Nvidia GeForce 9800gt 1024Mb

 

Placa de sonido Realtek ALC1200

 

 

Agradeceria si me pudieran ayudar con este tema, llevo tiempo batallando y no consigo la forma de hacerlo funcionar.

 

Muchas gracias

Share this post


Link to post
Share on other sites
Advertisement

Hola. Por favor revisa este tópico que seguramente te pueda aclarar dudas y servirte de referencia para fijar la inyección: http://www.insanelym...gt-solucionado/

Aquí también hay explicaciones muy buenas: http://www.insanelymac.com/forum/topic/252525-enable-nvidia-drivers/

Igualmente recuerda que cada vez que quieras probar inyecciones bien sea a través de DSDT o cadena efi (EFI String), debes establecer el parámetro "GraphicsEnabler=No", de lo contrario chameleon o el bootloader que uses siempre se anticipará a cualquier otra inyección. Por favor cuéntanos cómo te va. Saludos.

Share this post


Link to post
Share on other sites

Hola

Llevo varios dias intentando crear correctamente en dsdt.aml, pero ahora si que estoy parado y no se que mas puedo hacer.

He conseguido que el dsdt, pueda arrancar por VGA, por DVI y por HDMI individualmente, pero no tengo aceleracion grafica, y no puedo cambiar la resolucion siempre esta a 1024x768

Tengo el Graphics Enabler en NO

 

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">

<plist version="1.0">

<dict>

<key>EthernetBuiltIn</key>

<string>Yes</string>

<key>GenerateCStates</key>

<string>Yes</string>

<key>GeneratePStates</key>

<string>Yes</string>

<key>GraphicsEnabler</key>

<string>No</string>

<key>Kernel</key>

<string>mach_kernel</string>

<key>Kernel Flags</key>

<string>darkwake=0</string>

<key>Legacy Logo</key>

<string>Yes</string>

<key>Timeout</key>

<string>4</string>

<key>UseKernelCache</key>

<string>Yes</string>

</dict>

</plist>

 

Aunque puedo arrancar individualmente por cada puerto (VGA,DVI,HDMI), cuando arranco con dos puertos a la vez (ejemplo DVI-HDMI), solamente veo por DVI y HDMI no tiene señal, no puedo duplicar los monitores.

¿Para la aceleración grafica se tendría que poner algún KEXTS o este daria prioridad sobre el dsdt.aml, y el dsdt no funcionaria?

¿Para poder conectar los dos monitores a la vez, que podría probar?

Os dejo el dsdt.aml a ver si veis algún error que corriga este problema y tambien os dejo unas imagenes de los graficos y tarjeta pci

Gracias

DSDT.aml.zip

post-733110-0-58009800-1352671065_thumb.png

post-733110-0-48835700-1352671074_thumb.png

Share this post


Link to post
Share on other sites

Hola, estoy mirando que puedo hacer para solucionar este problema, pero no doy con la clave, estoy desesperado

Me podria ayudar alguien, por favor

Gracias

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×