Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
cassiouru

Macbook formatado para clean install do ML, EFI boot mostra erro do windows

3 posts in this topic

Recommended Posts

Olá pessoal. Dei uma pesquisada antes de postar mas não pude encontrar nada que ajuda-se.

 

Eu estava usando o Mac com um boot triplo, OS Lion, Windows 7, Ubuntu.

Formatei o mac inteiro pra instalar o Mountain lion do zero. Logo após separei uma partição pro Ubuntu.

Usei o rEFit pra esoclher qual sistema usar, ai que aparecem as coisas estranhas. O rEFit ainda mostra as antigas opções do Windows, mostrava também dois icones do linux, um do ML e um outro desconhecido.

 

Formatei as partições extras e juntei novamente ao Macintosh HD, deletei o rEFit.

E iniciei usando o option pra ver o que aparecia.

Apareceu Macintosh HD

EFI Boot

Recovery

 

Escolhendo esse EFI Boot, ele aparece uma tela azul do windows alegando falta de arquivos pra iniciar...

Quero limpar isso tudo, existe algum modo de limpar o EFI que deve conter arquivos de boot dos antigos sistemas?

 

Obrigado desde já!

Share this post


Link to post
Share on other sites

AQUI un exemplo, tens que ver qual o teu disco.

 

*Montar partición EFI

sudo -s

mkdir /Volumes/EFI

mount_hfs /dev/disk0s1 /Volumes/EFI (disk0s1 0=nº de disco)(1=nº particion)

killall Finder

*Desmontar partición EFI

sudo -s

umount -f /Volumes/EFI

rm -rf /Volumes/EFI

killall Finder

*Borrar Partición EFI

diskutil eraseVolume "HFS+" "EFI" /dev/disk0s1

*Si por algn motivo al querer montar la partición EFI obtenemos el mensaje "mount_hfs: Invalid argument" abrimos un terminal y tecleamos

fsck_hfs /dev/disk3s1 X=n de disco

Share this post


Link to post
Share on other sites

AQUI un exemplo, tens que ver qual o teu disco.

 

 

*Montar partición EFI

sudo -s

mkdir /Volumes/EFI

mount_hfs /dev/disk0s1 /Volumes/EFI (disk0s1 0=nº de disco)(1=nº particion)

killall Finder

*Desmontar partición EFI

sudo -s

umount -f /Volumes/EFI

rm -rf /Volumes/EFI

killall Finder

*Borrar Partición EFI

diskutil eraseVolume "HFS+" "EFI" /dev/disk0s1

 

*Si por algn motivo al querer montar la partición EFI obtenemos el mensaje "mount_hfs: Invalid argument" abrimos un terminal y tecleamos

fsck_hfs /dev/disk3s1 X=n de disco

 

 

Muito Obrigado iFire! Resolveu o problema!

EFI sumiu do menu option.

 

Mais tarde vou tentar instalar o ubuntu mais o seven e ver como ficará.

Mais uma vez obrigado pela ajuda!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×