Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Rowas

DigiDal.kext - The bane of a Lion Pro Tools Workstation (For me)

4 posts in this topic

Recommended Posts

This story starts quite a while back (Not really. It was more like 7 months ago.)

 

I had just gotten my Big Bang Xpower with an i7 and I'm looking to install lion on it and use it with Pro Tools. The installation goes fine, with graphics acceleration and everything. I install Pro Tools 8 and restart. Digidal.kext gives me a kernel panic and the only way I can boot in is with the kext deleted. I don't know why this happens and research gives me nothing. :(

 

Fast forward a little: Lion is okay with me, although there are a few things I don't like, but nonetheless I had to give it up for for a Snow Leopard installation. It turns out that Pro Tools works perfectly fine on SL, plus I have everything working anyways. So this is how it has been to this day.

 

Present day: My brother is getting married and he has enjoyed my workstation a lot (Played Max payne on full settings on Windows, Records lives sessions in Snow Leopard), so he bought components for me to install Mac for him to have his own workstation. I cannot get Snow Leopard to work on this one. I mean I can, but graphics just refuse to work. I try and try for two weeks, but no cigar.

 

I raised the white flag a couple of days back and installed Lion. Everything works out of the friggin' box. Both cards (GTX 460's) work fully (Full Acceleration on both + HDMI). Audio works and everything is fine and dandy.

 

Everything that is, except for... PRO TOOLS! Digidal.kext has returned to ruin my day and I need to know how to end this fight once and for all. My brother needs an audio Worksstation, not a Sortofworksstation. If he can't use Pro Tools, then that defeats the purpose of this setup.

 

Someone please tell me how to get it working.

 

As a side note, Pro Tools 8 would start up fine in Lion with Digidal.kext deleted, but when I hit the play button, I would get an "Assertion Error" which I think is attributed to the missing Digidal kext.

Share this post


Link to post
Share on other sites

Is it Protools HD with PCIe cards? If it's not, then you can remove this kext rebuild caches and forget about this problem.

Share this post


Link to post
Share on other sites

Nope. No cards here. I tried removing the kext after a successful PT8 Install, but I get an error inside the application (Assertion Error..... line xxx) whenever I try to hit the play button.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Did you tried use ACPIBatteryManager.kext for the Battery? And for brightness you can use IntelBacklight  Both created by @RehabMan 
    • I have put it into clover drivers 64uefi folder on Yosemite thru High Sierra which allows me to edit my High Sierra disk if needed in Yosemite system.   There is no functionality of apfs in other versions but it does allow other clover bootloaders and systems to recognize the HS apfs drive or open it for inspection.   If you don’t have it you can’t see your HS drive or access it in another macOS version.
    • Hi! Is it possible to get codec AD1981 running with AppleHDA on HP Compaq 8710w? It works nicely with VoodooHDA. Speakers and HP are switching automatically.  Internal and HP mic also work - no switching in SysPref but it works when mic is plugged in and internal mic works when hp mic is unplugged.   It has same weird pathmap - connected directly:  Playback: nid=5 [pin: Speaker (Analog)] | + <- nid=3 [audio output] [src: pcm] bindSeq=00008001 nid=6 [pin: Headphones (Grey Left)] | + <- nid=3 [audio output] [src: pcm] bindSeq=00008001   But inputs are really weird. There are 5 nodes from input to HP mic/Internal mic nid=4 [audio input] | + <- nid=21 [audio selector] [src: mix] bindSeq=00000003 | + <- nid=12 [audio mixer] [src: mix] bindSeq=00000003 | + <- nid=30 [audio selector] [src: mic] bindSeq=00000001 | + <- nid=8 [pin: Microphone (Grey Left)] [src: mic] bindSeq=00000001 + <- nid=31 [audio selector] [src: monitor] bindSeq=00000002 | + <- nid=24 [pin: Microphone (Analog)] [src: monitor] bindSeq=00000002 Can pathmap like that even work with AppleHDA? What codec should I patch? I tried patches from AD1984 but no luck.    These are manually patched verbs: 00571c10 00571d01 00571e17 00571f90 00570C02 00671c20 00671d10 00671e21 00671f03 00771cf0 00771d00 00771e00 00771f40 00871c30 00871d10 00871e81 00871f03 00971cf0 00971d00 00971e00 00971f40 00a71cf0 00a71d00 00a71e00 00a71f40 01671cf0 01671d00 01671e00 01671f40 01771cf0 01771d00 01771e00 01771f40 01871c40 01871d01 01871ea0 01871f90 01971cf0 01971d00 01971e00 01971f40   Codecgraph and linux codecdump attached. Thx for any help or suggestions.              codec.txt 2.svg codec.txt
    •   Yes, 'cause APFS log is coming before clover boot screen.
    • and you suspect apfs on before clover issues  


×