Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
Tim182

GA-Z77-D3H and 10.8

Recommended Posts

I have managed to get 10.8 running fine on the following set-up, except the sound:

 

GA-Z77-D3H

i5 3570K

HD4000

 

I have tried all of the following, none of which worked:

- deleted applehda.kext, fixed permissions and installed voodoohda 2.7.3

- did the same for 2.7.4

- I have have changed the device ID

 

The computer boots fine with voodoohda, no kernel panic, however when I try to open the voodoo panel I get the following error: "Can't get registry entry-path"

 

The motherboard uses the VIA2021 chip

 

Has anyone succeeded getting this to work?

Share this post


Link to post
Share on other sites
Advertisement

Open system preferences in 32 mode and see,have error?

Share this post


Link to post
Share on other sites

Open system preferences in 32 mode and see,have error?

 

Makes no difference. I get the following errors:

 

- Wrong channels number 0..24

- Can't get registry-entry path

Share this post


Link to post
Share on other sites

Version prefpane is the sime like kext -2.7.3?install Voodo HDA setings loader?

Share this post


Link to post
Share on other sites

Thanks, I tried this method with the following results:

 

 

I deleted the original APPLEHDA and installed the new APPLEHDA and VIA2021 using kext utility. I restart and so far so good, no panics.

 

I then copied the DSDT.aml into the /extra folder, restart and get a kernel panic.

 

I have the GA-Z77-D3H (not x, m or DS3H) on F14. Processor is the i3570 and I am using HD4000. The bios setting are on default expect SATA which is set to ACHI.

 

Something must be causing the kernel panic on boot with the DSDT, especially since I am running the the same motherboard. I have tried editing the DSDT manually and the sound shows up in the preference panel, however no sound comes out of the speakers...

 

 

 

Any ideas?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×