Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Which OS X version for Inspiron 1545?

2 posts in this topic

Recommended Posts

I want to make my secondary laptop, a Dell Inspiron 1545, a hackintosh, but I'm not sure which version of OS X to put on it that would run reasonably well. The main purpose of running OS X would be to run Apple Pro Logic, but I would be willing to use an old version of Logic in order to not crash my computer. Here are the specs: http://www.amazon.com/Dell-Inspiron-15-6-Inch-Black-Laptop/dp/B002PY7OKI

Share this post

Link to post
Share on other sites

If your only interested in running logic you may as well go with snow leopard. update it to 10.6.8 and use that, (Lion / ML still have updates coming which could cause you problems in future and there's no real reason to bother with them unless you have specific use / want of them).


See here:


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Discount_Mac
      I have done a semi-successful install of macOS Sierra 10.12.6 on my Dell OptiPlex 3010. When I mean semi-successful, I mean I have some issues left, one of them is Networking.
      Networking, meaning Ethernet, does not seem to work on this machine after installing Mac OS. I've tried installing kext files, reinstalling Sierra, and so on but nothing seems to work, I have an Ethernet cable plugged and it's lights flashing and whatever but the connection does not show up in Sierra.
      My PC Specs are:
      Dell OptiPlex 3010 MT
      Intel Core i3-3240 @ 3.40GHz
      AMD Radeon HD 7470
      4GB of RAM
      Realtek RTL8111E
      So, Any Help?
    • By Trung_Nguyen
      Hello everyone, 
      I'm getting these error at verbose boot, It waits at this line a little bit long. I think it's a DSDT error:

      Here is my DSDT:DSDT.zip
      Could someone help me fix this? Thank you all!.
    • By Trung_Nguyen
      Hello everyone,
      I am trying make the fix keyboard backlight on Dell Latitude E6230. It currently works but the macOS not recognized it. There is a keyboard shortcut which had 6 states of bright. I'm using IOWMIFamily to use the display brightness shortcut(Fn Up/Down) Is there a way to make the Ultimate keyboard backlight slider like in Debian?

      P/s: By the way, what is the ADB codes for VidMirror? I want to remap it because it controlled by PS2 and currently map to cmd+P(print) Thanks again
    • By Zsparrow0
      NOT WORKING   SD Card Reader (Use USB adapter ) Hibernation Nvidia Graphic Cards Fingerprint Reader Thunderbolt HotPlug REQUIREMENTS   Fresh installation One working OSX environment Whole disk available (No partitions) Knowledge in PLIST edition Backup Made (EVERYTHING WILL BE ERASED) Latest BIOS version 4k sector patch NVME WIFI CARD DW1560 (EFI FOLDER CONTAIN PATCH FOR THIS CARD ONLY)     1 - CREATE USB     Download High Sierra from AppStore Plug in your USB Key (16GB or More) Format it with Disk Utility and name it « MyVolume » Launch Terminal and type : sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume Mount the EFI partition /MyVolume/EFI/ with Clover Configurator (See in the EFI Folder) Copy the entire EFI folder linked to the post to /MyVolume/ 2 - BIOS SETTINGS   MAKE SURE EVERYTHING IS CORRECT BEFORE CONTINUE OR IT WILL FAIL ON BOOT !     System Information          Check that Video Memory is already 64MB       Advanced Boot Options (all off)        System Configuration      SATA Operation (AHCI)      Drives (all on)      SMART Reporting (on)      USB Configuration (all on)      Dell Type-C Dock Configuration (on)      Thunderbolt Adapter Configuration (all on, no security)      USB PowerShare (on)      Audio (all on)      Touchscreen (on)      Miscellaneous Devices (all on except SD Card Reader)      CPU XD (on)      Secure Boot        Secure Boot Enable (disabled)      Intel Software Guard Extensions        Intel SGX Enable (Software-Controlled)      Performance        (Everything on/enabled)        Power Management        (USB Wake Support = off)      (Wake on Dell USB-C Dock = on)       Wake on WLAN (off)      Block Sleep (off)        Virtualization Support        (Everything on)    3 - BOOT PROCESS
        Start your computer and press F12 to open the boot menu Boot from your USB Key Select the "Installer from (Your usb key)" (Verbose mode is enable by default to see what's going on if it fail)   -----------------------------------------------------------------------------------------------------------------------------------------     WAIT ! EVEN IF YOU THINK THAT THE LOADING BAR IS STUCKED IT COULD TAKE 5MIN TO LOAD ENTIRELY     IF IT FAIL SEE THE REHABMAN GUIDE BEFORE ASKING QUESTION     IF YOU CAN'T BOOT YOU CAN TRY TO USE A FAKE IG-PLATFORM GO TO THE CLOVER OPTION IN THE GRAPHIC PARTS AND USE A FAKE IG-PLATFORM SUCH AS 34567898764   ----------------------------------------------------------------------------------------------------------     4 - INSTALLATION   - Once arrived on the installation screen - Open Disk Utility and Erase your Main Hard Drive and format to : MacOS AFPS (not encrypted) - Go back to the installer continue and choose your Formated Hard Drive to install MacOS. - The computer will reboot after about 2 min - Press F12 to choose your usb key and hit ENTER   (YOU COULD HAVE 2 CHOICE DURING THE REBOOT : INSTALLER ON "YOUR DRIVE NAME" OR PRELOADER "YOUR DRIVE NAME". You have to use "Installer on your "drive name" in case it FAIL select the OTHER OPTION. You will have to do this twice if I remember correctly.   BE CAREFUL YOU HAVE TO ALWAYS BOOT ON YOUR USB KEY BECAUSE CLOVER IS NOT YET INSTALLED ON THE SYSTEM, SO PRESS F12 ON EVERY REBOOT AND CHOOSE YOUR USB KEY UNTIL CLOVER PROPERLY INSTALLED     5 - POST INSTALLATION   - Open Kext Wizard in My EFI folder - Click on installation tabs browse kext and select ALL THE KEXT IN USB/EFI/CLOVER/KEXT/OTHER - Make sure that the destination drive is your MAIN HARD DRIVE and press INSTALL - Once done go to MAINTENANCE TAB and select the radio button for System/Library/Extensions and press EXECUTE.   6 - RESTART WITHOUT USB   - Disconnect your usb and reboot normally, everything should work properly now.     !!! CONGRATULATION YOU DID IT !!!               if not...       Give us enough clear information in the comments section so we can help you to have this laptop working.   A BIG         TO     Dell for making this laptop Apple for Mac OS RehabMan for so many detailed posts, enormous collection of SSDT files, kext development, and being overall incredibly helpful throughout this whole process KNNSpeed for this amazing guide Pike R. Alpha for his in-depth blog and the 0xE2 patch (among being the source of many other developments and patches) The Clover team for the Clover bootloader netkas, kozlek, and Slice for FakeSMC wmchris for his initial XPS 9550 write-up Jonny4911 for posting his 9560 setup and his version of the AudioFix folder syscl for a lot of work into the XPS 9360 and his build of VoodooPS2Controller darkhandz for his XPS 9550 repo toleda and goodwin_c for audio, ALCPlugFix goodwin_c for HWP dpassmor for the Thunderbolt/USB-C ExpressCard trick vit9696 for Lilu and AppleALC PMHeart for CoreDisplayFixup lvs1974 for NvidiaGraphicsFixup darkvoid for Wi-Fi patches filequit for the 5GHz global channel bonding patch denskop for the "Boot Graphics Glitch" patch netkas, kid2010, and syscl for the Thunderbolt 3 blacklist bypass patch Blazinsmokey for all his good advice and knowledge   AND ALL THE OTHER THAT I DIDN'T QUOTE BUT WHO CONTRIBUTED TO MAKE THIS DREAM HAPPENED !     MORE CUSTOMIZATION   Improve battery life and CPU temperature :   Check the @abn6x Guide : http://www.insanelymac.com/forum/topic/331775-guide-how-to-undervolt-your-haswell-and-above-cpu/     EFI.7z
    • By wiewiorcwaniak
      I have problem with my first hdd probably with mbr - Windows from first hard disk do not boot I am not sure if it is caused by OSX or two magnets from my broken e-cig (so another problem this day) that I've placed 20 cm from my laptop ;-) but fail boot is on main ssds, hdd where OSX is installed works fine
      I have huge question and I wanna quit help, I've installed Sierra about week ago and I do not know/have time to add proper settings to make Windows boot with clover - clover is on hdd not ssd... but when I tried to boot windows from there I only have white square when I wanna boot Windows on SSD. For but at this time I used only booting drives from bios because I do not know much how to setup it in proper way.s
      So please help me... because I do have lot of programs that I've using with Windows and I do not have option to boot this god damn thing...
      Any help will be very helpful... I do not have much time this day to find tuts, but if you have good tut please give me a link (I do not wanna search in this situation because I do not wanna screw my lats os that actually is operable. Also I have only lan connection and also not a long time to use it now, but I will read your posts on tablet.
      So much thanks for any kind of help
      Edit: Another question how to trust computer to use it with AppStore properly via clover configurator, u use clover.plist posted by another user i wathed Video tut on youtube but probably i’ve done it wrong way on smbios setting i use same type of mac that is showed on the original config but OS X refused to boot. I am happy that i have pendrive with installer and original files so now Sierra booted Ok. So what should i do or that way so what i’ve done wrong?