Jump to content

ML & Asus P6T SE & Sapphire Radeon 5750 1 GB GDDR5 succes


3 posts in this topic

Recommended Posts

This allmoast drove me crazy but I never gave up though I was so close lol. Ive been trying to make three displays working with this card for over a year now.


Also English is not my first language so I probably use way to many words but please bare with me Im doing my best here lol.


This is not in anyway a guide cause Im just not the right guy to put one together. Short story is in reality Im just a noob that got lucky with this specific video card, thats it.


The installation method I used for ML is one of the USB flash drive ones that you find here.


What was strange though is that Chameleon wouldnt create the Extra folder on ML (like we are used to) so I had to copy the Extra folder I already had on my Lion install over to the ML drive.


I tried a few Chameleon versions but it was the same with all of them. Dont ask me why I dont know cause like I said Im just a noob.


The version I used is the latest one though if I remember it right but that doesnt mean I say it wont work with another one. Like I said Im just a noob so I wouldn't know.


The boot time kind of sucks though, its way to loooooong but hopefully that will change if someone that knows what theyre doing digs in here and fix it.


So once you have ML up running just copy paste the AMDRadeonAccelerator.kext and the ATIController.kext to your desktop.


You should also backup the two kexts to a safe place if stuff goes wrong.


Then edit them by rightklick and pick Show package content/Contents/Info.plist and add the id for this card which is 0x68BE1002 or 0x68be1002. Im a little confused here so I cant say for sure if the BE part have to be in capitals or not so you have to experiment yourself to find out.


In my ATIController.kext though its in capitals (0x68BE1002) but in my AMDRadeonAccelerator.kext its not (its 0x68be1002) but thats pretty much probably only by accident. Anyway it works so who cares lol.


In the AMDRadeonAccelerator.kext info.plist you have to scroll way down to where it say






















<string>0x68B81002 0x68B01002 0x68B11002 0x68A01002 0x68A11002 0x68be1002</string>


and add the id just like it say in the line over here.


In the ATIController.kext you wont have to scroll down so far though






<string>0x68981002 0x68991002 0x68E01002 0x68E11002 0x68D81002 0x68C01002 0x68C11002 0x68D91002 0x68B81002 0x68B01002 0x68BE1002 0x68A01002 0x68A11002 </string>


Use Texteditor to do the modifications. Its already in os x and works great for this so you wont have to download anything.


Use kextutility or whatever program you usually do to install the kexts back to the Extensions folder.


Good luck hope it works for you guys too.

Link to comment
Share on other sites

I believe it still the same but it seem to work better now, gonna do some more testing and report back. I found out the gpu namde is Juniper in windows and pretty much by accident decided to look in to the accelerator kext splist. While I was scrolling down in the plist I suddenly see Juniper so I stopped took a closer look at the IDs for Juniper and I realized mine wasnt there so I added it and rebooted and it worked.


I already had fixed it in the 5000 kext so I had basic functionality but no QE. Whats strange though is that in windows it shows as 0x68BE1002 in kapitals so thats what I typed in the 5000 kext plist. Thats was a couple of hours before so I had forgot about it and when I finnaly ended up desperately :D messing with the accelerator kext I added 0x68be1002 instead by mistake.


Anyway it doesnt seem to matter cause it looks like its working ok. The boot time for ML is very slow though. First install I tried to updating a 10.6.8 I already had on one of my SSD drives which actually worked but the boot time for it is like forever. It goes on and on and on and on ...... before it finally boots up.


Next I did a couple of clean installs to a Sata drive and it seem to work better. Its still very slow though but only half the time compared to the updated SSD drive.

Link to comment
Share on other sites


  • Create New...