Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


iDeneb on Gateway T-1628 (Sort of working, still needs some things)

1 post in this topic

Recommended Posts

Hey thanks for looking at my post! As the family tech support guy, I inherited a non-functional Gateway laptop from my mom to play around with. Long story short, I pulled a bad stick of Ram out and VOILA! it works. So I decided what the heck? Let's try to make this work on OSX...


I'm writing this here for a couple of reasons:

1. If it helps someone else along the way fantastic

2. There are some things that are still not working and if I could get some advice I'd appreciate it.


I didn't really know what I was doing the first few times I installed so I'm going to just start at my most recent install (when I had really started to figure stuff out)


I used the iDeneb1.6 dvd to load OSX 10.5.8 on a partition of the 250gb hdd, based on the T-1625 tutorial in the wiki.

Kernel: Voodoo

Drivers/Fixes/etc: OldApplePS2 (tried w/o and trackpad didn't work), AppleATIATA, AppleDecrypt, Disabler, IONetworkingFamily, RTL8187b, OpenHaltRestart, Seatbelt


What works:


Wired ethernet

Expose (I've missed this so much being on windows for the last two years!)

Edit: Wifi


I used to use a PBG4 on Tiger back in the day. But it's pretty much obsolete now. I say that because I know my way around the basics of OSX to some extent. Some of the stuff I'm working on is more essential (wifi) but some is just because I liked using those features (trackpad stuff, etc):


Sound (from my understanding it won't because of my ATI Radeon x1270 board)

Resolution changing (same reason)

Wifi (I thought that installing the RTL8187b would fix this but apparently not?)

Scrolling/Clicking with trackpad (not essential but would be convenient)

Webcam (recognized correctly in system so I'm going to look into the proper kext for that)


If anybody has suggestions or questions they are always welcome. My biggest issue is wifi. I have an ethernet cord for the house but really isn't a laptop kinda pointless without wifi anymore? I'll update this as I get it more functional. If I can finish it to be as functional as I want I'll post in tutorial.


Edit: used ethernet to go find correct kext for wifi. It works but the only problem is the Realtek client doesn't work for WPA enterprise so I can't use the wifi at school. Oh well I can learn to live with that.


I was able to change the resolution with some kext I found searching through the forums, but it made my cursor a large square so I just went into the boot.plist and edited it manually to a static resolution.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.