Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Macbook Pro A1226 Weird Problem. Stuck On Gray Screen.

3 posts in this topic

Recommended Posts



I have this awesome Macbook Pro A1226 with the 2.2GHz Core 2 Duo.


It was working fine all this time and just recently it has been getting stuck on the gray Apple loading screen. It had Snow Leopard 10.6.8 but I was able to get it to work for about a complete day and I was able to update it to 10.7 with no problems. But then it started doing the same thing.


I was able to get my hands on the Apple Diagnostics Disk and it has passed all the tests. Memory, Logic Board Tests, Hard Drive, etc.


It is very weird that it still refuses to boot. It will not even boot off the installation media. I have tried 10.6 Retail, 10.6.3 Retail and a 10.7 Lion Disc that I made. And still nothing. I removed the hard drive and stuck it onto another mac and disc utility reports that it is good. I have tried booting from external firewire and external disc drive and it still gets stuck on the same screen.


So what I did also, I booted with the Command + V key for Verbose mode and it always seems to get stuck at the same problem. Right after it says




"nstat_lookup_entry failed: 2




So I am hoping someone can help me out.

Share this post

Link to post
Share on other sites

I did. Somehow the stupid thing started working. I am thinking of just reinstalling the operating system. Get the gremlins out of the way.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.