Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Alienware m14x

2 posts in this topic

Recommended Posts

Hello, I'm new to the forums, so please forgive me if there is already a topic on this somewhere.


I've installed Mac OS X 10.6 on my Alienware M14x and it boots fine, and is operational (minus the USB, network, audio and QE/CI as I have not installed any kexts for them yet, and I intend to later if someone can help me with my current problem)


When I update to 10.6.7 (since 10.6.8 direct updates give me a kernel panic), both my i Boot CD or the Chimera bootloader I installed to the hard drive cannot boot correctly. When I try to boot with chimera, it instantly crashes to the bios, even with the verbose boot flag listed. When I use i Boot, it cannot find the hard drive and constantly say "still waiting for root device"


So, my current problem is that I cannot get into OS X at all and I've tried looking everywhere on multiple forums for help, but everything I've tried doesn't work. Here are my specs:


Alienware M14x R1

Intel Core i5 2410M 2.30 GHz

8 GB DDR3 1330MHz RAM

Intel HD Graphics 3000/NVIDIA GeForce GT 555m Graphics Card

Seagate Momentus 9750420AS 750GB Hard Drive


My SATA settings are already set to ACHI mode.


Any help please?


Just in case: I legally own a copy of Mac OS X Snow Leopard (and Lion as well, but the osx86project wiki said to go with a snow leopard install first, but I can't even get that running. :worried_anim: )

Share this post

Link to post
Share on other sites

UPDATE: While looking through the verbose boot log, I found that i Boot wasn't loading my AHCI driver for some reason. The specific error is:


"Can't load kext com.apple.driver.AppleAHCIPort failed to load (error 0xdc008016)"


I'm assuming that this means I need a chipset driver. Now the question is where to find one. It's a good thing I put ###### on a CD-RW so I can add kexts to it.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.